This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

tox

Forum Replies Created

Viewing 15 replies - 1 through 15 (of 16 total)
  • Author
    Replies
  • in reply to: site speed turning into a crawl #3529
    tox
    Member

    Thanks for your response, Jason.
    I already turned on Supercache and that is helping a bit. Thanks for adding that your theme is more load intensive, that together with WPML may indeed be the cause of some of the slowness. But it should obviously not lead to an unreachable site, so will turn to the host instead.
    Thanks again for your support,
    Piet

    in reply to: WPML issues with custom homepage layouts #2490
    tox
    Member

    cool, thanks Jason

    in reply to: WPML issues with custom homepage layouts #2487
    tox
    Member

    Hi Jason,
    Yes, I found the option and ticked the box off.
    Regarding the future posts, it was indeed some kind of plugin conflict, at last I managed to actually schedule all future posts in the secondary languages.
    One last question: I added the wp_reset_query with the hook you mentioned. You also said that in the next version this will be fixed. Does that mean that when Torkel updates the theme I need to get rid of that hook in the Child Theme’s functions.php file?

    in reply to: WPML issues with custom homepage layouts #2480
    tox
    Member

    Hi Jason, thanks so much for your very detailed reply.

    I have immediately implemented your 2nd option that you also have working on your test site and it indeed immediately works perfect. I only noticed that the slider now also pops up on this page, so I will need to dive into the theme to see how I can disable that…

    Regarding the future posts I admit that it is weird and on my own test setup it works as it should as well. I will have another long look at the different plugins that have been installed on the site. At least we can now conclude that it has nothing to do with your theme and/or WPML.

    Regarding the category names not showing up correctly I think it has to do with what you wrote:
    I will admit this is probably not ideal with working with WPML because you’d have to ensure that you never opened and saved a layout of one language while under another language. This could get messy in the long run.

    Let’s leave that for now as it is working on the homepage now and if it would fail in the future (I don’t believe it will) then for the homepage we can also implement the post list page template.

    Again, many thanks for your support!

    in reply to: WPML issues with custom homepage layouts #2470
    tox
    Member

    Hi Jason,
    Piet here again. Do you have any news for us regarding the issues above?
    Please let me know, because if you cannot help Torkel further then we need to switch to plan B.
    Thanks,
    Piet

    in reply to: WPML issues with custom homepage layouts #2460
    tox
    Member

    Followup: I manually added do_action(‘icl_language_selector’); to swagger/framework/functions/display.php and that unfortunately had the exact same result: linking to the category instead of the correct page.

    in reply to: WPML issues with custom homepage layouts #2459
    tox
    Member

    Hi Jason, thanks for your reply.

    The above is also still an issue, the theme does not respect scheduled posts (to be published at a date in the future) for the secondary languages. The only way to solve that is to make drafts of the posts, but within Torkel’s user scenario that completely defeats the purpose and brings a lot of extra work for him.
    I actually have tested this on one of my own site setups and it works as it should, so perhaps there is something in the Swagger theme or in your theme-blvd-wpml-bridge plugin that does not check whether a published post has a future date (post_status=future)?

    Regarding my 2nd point (can I assume that you can confirm my 1st point?):
    The default WPML language switcher is set to show on the right sidebar and the problem only manifests itself on the Chapters page, which uses a Custom Layout that calls a post list from the chapters category (again with issue 1 as per my previous post).

    When you have a look at the Chapters Page: http://www.onthisday80yearsago.com/the-chapters/, please have a look at where the links of the language switcher point to. This should be the German equivalent of that page (http://www.onthisday80yearsago.com/de/kapiteluebersicht/), however instead it points to the German chapters category page (http://www.onthisday80yearsago.com/de/category/die-kapitel/). Usually the only time when this happens, is when page-slug and category-slug are exactly the same. However in this case the slugs are completely different, so I am unclear as to where this is coming from.

    I am inclined to physically add the language switcher to the sidebar (i.e. hard code it in the template files), but as I don’t know your theme I am not sure from where the sidebars are called. I found swagger/framework/api/sidebars.php; would it be possible to hook into that function from the functions file of the child theme?

    in reply to: WPML issues with custom homepage layouts #2454
    tox
    Member

    Dear Jason, this is Piet using Torkels login details as he mentioned above. I am helping him to get WPML to work correct on his website. Nice to meet you.

    The problems I have so far discovered are the following:
    1a. the custom layouts per language seem to work well, BUT when choosing the Post List element then the Categories of English (default language) show up for both German and Swedish (the secondary languages).
    I have made a screenshot available at: http://db.tt/IRNzyqKH

    1b. when using the WPML backend language switcher to change the language to for example German, then the same happens as above, but for all languages, so the in English it is impossible to choose the correct English category.

    2. the WPML frontend language switcher does not point to the correct content of the other languages. For example when I am on a Page, the WPML language switcher points to a category.

    I have been working with WPML since its inception and I have never come across this behaviour.

    Is there anything else you need from me?

    in reply to: .mo files #2442
    tox
    Member

    Thank you, very informative and to the point.

    in reply to: WPML issues with custom homepage layouts #2429
    tox
    Member

    Dear Jason, I have asked Piet Bos from Senlin Online http://senlinonline.com/ to help me sort out my problems. I have given him access to my account. He will probably try to contact you tomorrow. Please assist him. Warmest, Torkel

    in reply to: WPML issues with custom homepage layouts #1726
    tox
    Member

    Thank you for your reply. I have emailed log in details to the WPML team and they are looking at it now.

    in reply to: WPML issues with custom homepage layouts #1695
    tox
    Member

    Thank you Jason! Now the Custom Layouts work.

    But instead all languages do not show for all pages on the user end and some posts that are scheduled to be published later are showing in German and Swedish, which is incorrect. In English the posts scheduled for later publication are not showing (i.e. correct function). All this was working well before I updated to WP 3.5 and WPML v2.6.3. My Swagger is version 1.1.5 and WPML Bridge is v1.1.1.

    in reply to: WPML issues with custom homepage layouts #1677
    tox
    Member

    Thank you for your expediency but I am sorry to say that it still does not work. I have updated to the new version of WPML Bridge (1.1.1) and just as before; I can only set ONE Custom Layout that becomes the selection for ALL languages.

    in reply to: WPML issues with custom homepage layouts #1671
    tox
    Member

    It happened after the v2.6.3 update.

    in reply to: Change text on "View Post" link #852
    tox
    Member

    When I try this solution the filter does not get removed. I can not understand why. Should there be any more code than the one line snippet you suggest? I am not a developer so please explain if there is something basic that I am misunderstanding.

Viewing 15 replies - 1 through 15 (of 16 total)