This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

edsteenhoek

Forum Replies Created

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • in reply to: Portfolio Grid Page and breadcrumb #17756
    edsteenhoek
    Participant

    Thanks for the very quick update!
    I updated the plugin and it solves that part of my challenge.

    I also updated the portfolio items to no longer use custom layouts so the titles are also back.

    Next challenge is to create 3 different sidebars which is why I started using the custom layouts for portfolio items. What I want to achieve is:
    – The default goes with the blog posts.
    – One that goes with each of the 2 portfolio’s.

    I learned that I can assign a widget area based on a custom conditional statement.
    Using “is_singular( ‘portfolio_item’ )”, I can overwrite the default sidebar for all portfolio items.
    To differentiate between the portfolios I found that it works when I use “is_singular( ‘portfolio_item’ ) && has_term( ‘solutions’, ‘portfolio’ )”

    So it seems I’m all ok now or are there side-effects to this approach that I don’t oversee?

    Regards,
    Ed

    in reply to: Portfolio Grid Page and breadcrumb #17744
    edsteenhoek
    Participant

    Hi Jason,

    Thanks.

    I did try the plugin already (it is even still linking the portfolio item to the page) and it seemed to not do anything on portfolios but didn’t make the connection with the breadcrumb issue at that time. Looking forward to the update plugin.

    On the title issue I discovered some clue this morning, but let’s take it step by step.

    I did not modify anything (can’t even code PHP…). There is no child theme. All changes are configuration through the UI admin. Even the few CSS modifications are part of the Theme Options. So, code-wise all is still ‘out of the box’.

    In preparation of providing URL’s for you to look at, I noticed that this issue only applies to one of my two portfolio’s. When I did a side-by-side comparison between two portfolios where one didn’t have the title issue, I found the reason why the title was missing: it uses a custom layout.

    http://ic2014.edsteenhoek.nl/item/spa4d-2014/ uses the default layout and has a title.
    http://ic2014.edsteenhoek.nl/item/documentum/ uses a custom layout and misses the title.

    As soon as I reset the custom layout to “– None –” on http://ic2014.edsteenhoek.nl/item/documentum/, the title is back.

    Screenshot of the layout: http://s13.postimg.org/4dcxtg7lz/Services_EN_Layout_in_Builder.jpg
    Screenshot of assigning a custom layout: http://s23.postimg.org/emw3p1463/Custom_Layout_on_Portfolio_Item.jpg

    Yet, it leaves me clueless on why the custom layout removes the title…

    Regards,
    Ed

    edsteenhoek
    Participant

    Hello Jason,

    Including the post_type did the trick.

    And I do have to use &, not &
    As soon as I use &, on save of the widget, the first & is replaced by & and the second is not.
    So post_type=portfolio_item&portfolio=portfolio_slug&portfolio_tag=portfolio_tag_slug
    is translated in post_type=portfolio_item&portfolio=portfolio_slug&portfolio_tag=portfolio_tag_slug on save.

    What worked was post_type=portfolio_item&portfolio=portfolio_slug&portfolio_tag=portfolio_tag_slug

    It might be ok to use escaping in code, but since I’m using the UI in wp-admin/widgets.php, the escaping is probably done automatically and causes confusion if used in the string.

    Thanks!

    Regards,
    Ed

    in reply to: Solve impact on shadow from slider height change #17702
    edsteenhoek
    Participant

    Thanks.

    The second would have worked.

    There was another solution I ran in by accident: change the layout from stretch to boxed.
    It solved the issue and it turned out that boxed is the style I need.

    in reply to: Add media with caption means no lightbox? #14744
    edsteenhoek
    Participant

    Thanks for the fast reply.
    The url: http://orlando.edsteenhoek.nl/item/animal-kingdom/
    It is a restricted site, so I created an user and pw.
    Both: TBSupport.

    This is the setup I created:
    – Foto’s is a page of the post grid template.
    – It displays the portfolio called fotos.
    – That portfolio has a few portfolio items.
    – Animal Kingdom is one of the items and has several photos that I added with add media.
    – Because I removed the caption, add media now inserts the lightbox option.

    On the Foto’s page, each item has a caption which serves as a title of the photo collection in an item.
    On the Animal Kingdom page, none of the photo’s has a caption, but the lightbox does.
    Here too I want to add a title to the image.

    This is the text of the page:

    [lightbox_gallery]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8674.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8674-300x200.jpg" width="240" align="left" title="Macaw papegaai" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8687.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8687-300x200.jpg" width="240" align="left" title="Springbok (vrouwtje)" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8688.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8688-300x200.jpg" width="240" align="left" title="Springbok (mannetje)" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8689.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8689-300x200.jpg" width="240" align="left" title="Bengaalse tijger" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8753.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8753-300x168.jpg" width="240" align="left" title="Witte neushoorn" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8709.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8709-300x200.jpg" width="240" align="left" title="Kerkuil in vlucht tijdens de show" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8712.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8712-221x300.jpg" width="221" align="left" title="Kerkuil" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8679.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8679-199x300.jpg" width="199" align="left" title="Vleermuis" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8740.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8740-300x300.jpg" width="240" align="left" title="Uil" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8744.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8744-300x280.jpg" width="240" align="left" title="Uil" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8729.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8729-300x300.jpg" width="240" align="left" title="Amerikaanse zeearend" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8769.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8769-300x300.jpg" width="240" align="left" title="Giraffe" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8774.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8774-300x200.jpg" width="240" align="left" title="Giraffe" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8812.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8812-300x200.jpg" width="240" align="left" title="Zebra's" frame="true" icon="image"]
    [lightbox link="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8829.jpg" thumb="http://orlando.edsteenhoek.nl/wp-content/uploads/2014/02/Animal-Kingdom-2014-8829-300x200.jpg" width="240" align="left" title="Animal Kingdom" frame="true" icon="image"]
    [/lightbox_gallery]
    in reply to: Add media with caption means no lightbox? #14733
    edsteenhoek
    Participant

    The lightbox gallery does after the page has been published. Probably a hickup in the WordPress preview.
    Caption on the portfolio list page still is missing (it does show in the lightboxed images).

Viewing 6 replies - 1 through 6 (of 6 total)