This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

XAMPP – Develop locally then upload lost theme preferences

  • Creator
  • #8752


    I need to make some major changes to our company website so normally do this offline using XAMPP and then upload to live server. I do this via uploading every single file via FTP and importing the whole database using phpMyAdmin. Whether I download our live site to local server or upload from locally to live I always lose the “Alyeska Theme Options” and have to manually re-configure these. Why would this be if I’ve included every file and imported complete SQL database?


Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
  • #8764
    Jason Bobich


    This will correspond to how you’re handling your SQL database file you’re importing. If you’re running into this issue, it means you’re most likely doing something to the database upon transferring that is not taking into account the fact that there is serialized data.

    Your WordPress database contains enough serialized data for this to be an issue. Any large array of data stored is serialized. In terms of the theme, this includes theme options, custom layouts, custom sliders, etc. In terms of WordPress, a common thing people run into this is with widgets and their settings. Have you ever made a transfer the way you’re doing it and noticed your widgets didn’t transfer through right?

    A common reason people run into this is in trying to change the website URL in the database transfer file. However you’re doing this is most likely the issue.

    When you make the transfer using a tool like this to do your find/replace on the site url should eliminate the problem. —


    Hi – Thanks for your quick response. I was indeed doing a search/replace of website URL before import as many online resources suggest. I tried using the tool as suggested to keep the integrity of serialized data and it indeed solved the problem.


Viewing 2 replies - 1 through 2 (of 2 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.