This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

WPML 3.2 error- Warning: Missing argument 2 for SitePress::get_terms_args_filter

  • Creator
    Topic
  • #22793
    odyn
    Participant

    Hello,
    I’m getting the same problem as the guy in this topic
    http://support.themeblvd.com/forums/topic/wpml-sitepress-php-error-on-backend-due-to-layout-builder/
    except I’m using:
    jumpstart 1.2.7
    Layout builder 2.0.8

    First everything worked fine, later site started to show some error message (probably during some update; error message might have been the same as this; it mentioned wpml plugin) on the english site
    I updated the WPML and the language switchers dissapeared and now I’m not able to put them back as I keep getting this error in wpml settings (Language switcher options).

    Warning: Missing argument 2 for SitePress::get_terms_args_filter() in /domains/novagalerijaddt.si/public_html/wp-content/plugins/sitepress-multilingual-cms/sitepress.class.php on line 2699 1

    • This topic was modified 6 years, 9 months ago by Jason Bobich. Reason: Edited title to be more specific to issue for those searching the forums
Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #22805
    Jason Bobich
    Keymaster

    Hi,

    I’ve posted v1.2.8 on the Jump Start v1 track. You get the update by manually downloading the Jump Start v1 installable WordPress theme ZIP from your Downloads page. This should fix the issue you’re having with WPML 3.2.

    http://themeblvd.com/changelog/?theme=jumpstart-1

    Let me know if this doesn’t fix your issue.

    #23175
    NilsOla Nilsson
    Participant

    Hi,

    I got the same problem, and after manually updating to 1.2.8 i got another problem:
    ”could not connect to host”

    When turning on
    define( ‘WPML_DEBUG_INSTALLER’, true );
    in wp-config.php I got the following on my screen:

    POST http://api.wpml.org/
    Array
    (
    [body] => Array
    (
    [action] => site_key_validation
    [site_key] => xxxxxxxxxxx
    [site_url] => http://ulf.femtrappor.se
    [using_icl] =>
    [wpml_version] => 3.2.7
    )

    [timeout] => 45
    )

    WP_Error Object
    (
    [errors] => Array
    (
    [http_request_failed] => Array
    (
    [0] => couldn’t connect to host
    )

    )

    [error_data] => Array
    (
    )

    )

    (This is a testsite for my real site which is ulfsandstrom.se)

    Any idéa?
    Do you need more information?

    Regards NilsOla

    #23176
    NilsOla Nilsson
    Participant

    Solved (by wpml team! ) Thanks anyway.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.