This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Slider images won't load?

  • Creator
  • #7588

    Hi there,
    All was going great with the theme – just trying to add a slider to the home page, the images appear to upload but I get a little pad lock and a small red dot with a – sign in the middle where the image should appear, I can edit the image etc. but no image appears in the slider itself, the best I can get is the image title appearing and sliding across where the image should be…screen shot below.

    Any help much appreciated!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
  • #7597
    Jason Bobich


    The things in your screenshot (the attachment ID and the lock icon) are normal but the image not displaying is not correct. This would suggest there’s something weird with your site in general in uploading images to the media library.

    Are you currently able to upload images in general and display it on your site, like in pages and posts?

    What happens when you save the slider and display it on your site? Can I see a link to an example of this?


    Sure, the site is at

    Other images load fine, just seems to be the slider …

    Jason Bobich

    Other images load fine, just seems to be the slider …

    This is honestly unlikely. Something has to be wrong with your WP install on your server. The theme does not do anything in uploading the images, as this is all handled by WordPress. I know it’s easiest to blame the theme and ask for a solution, but unfortunately it’s not going to be that easy with something like this. Please take a little more time and troubleshoot your specific issue.

    I’m looking at your site and I don’t see images anywhere else on it. The only place I see images are on the homepage, however these images were not uploaded with WordPress’s media uploader.

    On your site, it is quite clear you have an issue with uploading media, as here is an image in your slider that WordPress has uploaded:×326.jpg — Notice how WordPress was able to generate the URL, but now your server can’t find it?


    (1) Go to a standard page, click the “Add Media” button and try to upload an and insert an image into the page through WordPress’s media manager. Does this not work? — Then, this tells us it’s not directly related to the slider.

    (2) Deactivate the theme, and activate the default TwentyTwelve theme. Go to a standard page, click the “Add Media” button and try to upload and insert an image into the page again. Does this not work, also? — Then, this tells us the issue doesn’t correspond to the Barely Corporate theme.


    Hi Jason, thanks for your reply.

    I’ve tried your suggestions and it appears it’s related to wordpress and not the theme;

    Troubleshoot 1: I get a broken link icon on the page
    Troubleshoot 2: Same again, broken link icon on the standard wordpress themes

    There seems to be some issue with the links that wordpress is generating;

    My media library displays 5 blank thumbnails for the images, indicating some broken link issue, however when i click on the thumbnails, i can edit the images.

    Even when I FTP images diretly to a folder, and insert in to the slider by URL method, hoping that the image would correctly index in the library, I still get the same problem…

    I understand this isn’t your problem, but i’m not sure what to do, re-install wordpress?

    Theme is great by the way 😉



    Turned out to just be the permissions settings on the directory…,

    Many thanks for your time Jason.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The forum ‘Barely Corporate Responsive WordPress Theme’ is closed to new topics and replies.