This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Search popup broken with Woocommerce installed

  • Creator
    Topic
  • #18080
    jtobler
    Participant

    Jason, I’m trying to figure out why I’m experiencing a conflict. Have Alyeska (3.01) installed over WP (3.9.1) with WooCommerce (WC – 2.1.12) – all the latest versions, that I can tell. I also have your latest WC patch installed.

    Either way, WC seems to be the culprit. If I disable it, the popup search field works. If it’s enabled, nothing happens. I’ve tried disabling lightbox and REST and other features, to no avail. Also tried disabling other plugins, but the only thing that breaks the menu-bar search field is WC.

    Also, probably related, is that the product variations in WC are not properly displaying (ie., a product with attributes should AJAX a dropdown of the price of the selected variation/attribute), but it’s not displaying.

    Any thoughts?

    • This topic was modified 6 years, 10 months ago by jtobler. Reason: Added issue with variation not loading properly - most likely related
Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #18085
    Jason Bobich
    Keymaster

    Hello,

    Can you show me a live link to these issues?

    #18086
    Jason Bobich
    Keymaster

    Also, have you tried with Alyeska 3.1? In 3.1, we did a big shift of how javascript files are arranged which fixed a lot of general third-party plugin javascript conflicts (everything you’re describing are frontend javsacript actions).

    #18090
    jtobler
    Participant

    Ok, I’m going to try 3.1 and see if that works.

    #18091
    jtobler
    Participant

    Ok, I updated to 3.1.4 and the search popup is still not working. Here is the site: http://showmeoutdoor.com

    Thanks for your willingness to help, Jason 🙂

    #18095
    Jason Bobich
    Keymaster

    I think something is out of whack with your woocommerce install. My console is saying you’re missing a JavaScript file from WooCommerce. Try deleting and reinstalling the plugin from wordpress.org. Make sure to fully clear your browser cache when you test again. Then if that doesn’t work, can you activate one of the default WP themes and let me take a look? I’d like to see if the same JavaScript errors are present. I could be wrong, but it seems the issue is from this WooCommerce file not being pulled from your server.

    #18096
    Jason Bobich
    Keymaster

    My hunch is that specifically is your issue:

    http://showmeoutdoor.com/wp-content/plugins/woocommerce/assets/js/jquery-cookie/jquery.cookie.min.js

    … This file is part of the WooCommerce plugin and should be coming up on your server. I think there may be some kind of server issue with the file, for whatever reason. If you go to a file address that doesn’t exist, you’d be redirected to your WP 404 page, but that’s not happening here. So, I think the file is there, just for some reason it’s being blocked on your server.

    #18097
    Jason Bobich
    Keymaster
    #18140
    jtobler
    Participant

    That worked, Jason. Thanks, again. I don’t think I would’ve caught that one.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.