This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Relationship between version+theme framework

  • Creator
  • #9666

    Using Alyeska 2.1.5 with Framework 2.1.0. Would like to add a plugin that requires 2.2 framework. What is the relationship between the two and how do you upgrade?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
  • #9676
    Jason Bobich


    You’re not able to upgrade. What you have in your theme is what you have, essentially. The way this all works is over time I improve the framework, increasing the version. Then I work these into theme updates over time, which is a tremendous amount of work.

    The next version of Alyeska coming really soon will be Alyeska 3.0 with framework 2.3.0. This will open doors to a lot of plugins out there, as actually now in Alyeska 3.0, all functionality relating to widgets, shortcodes, sliders, and custom layouts has been moved out of Alyeska; users will now need to use the respective plugins. It’s all part of a big process that we’ve been working on for some time.


    why am I getting this message and would this cause my floating widget areas not to work
    You currently have the “Theme Blvd Widget Pack” plugin activated, however you are not using a theme with Theme Blvd Framework v2.2+, and so this plugin will not do anything.

    Jason Bobich

    The message basically means exactly what it’s saying. If you’re seeing it, it means you’re using a prior version of Alyeska, and so the plugin isn’t going to do anything.

    Alyeska 2.1 contains framework v2.1.
    Alyeska 3.0 contains framework v2.3.

    In Alyeska 3.0, the widgets were moved to the Widget Pack plugin. If you’re using a prior version of Alyeska, you already have the widgets in the theme, and thus you don’t need the plugin.

    Note that the “Widget Pack” plugin is separate from the “Widget Areas” plugin — These are two separate things.

    So, the following plugins should only be used if you’re using Alyeska 3.0+ —

    Theme Blvd Layout Builder
    Theme Blvd Sliders
    Theme Blvd Widget Areas
    Theme Blvd Widget Pack
    Theme Blvd Shortcodes


    Hi, I definitely broke some functionality on my site by doing this. Now my previous shortcodes don’t seem to work.

    Anyway, can’t we simply download the most recent Alyeska theme (alyeska-3.1.6) to replace our alyeska 2.1? Will that work?

    Sorry, sort of new to this and trying to figure it all out.

    BTW, I’m currently
    – Alyeska Child Theme with Theme Blvd Framework 2.0.5
    – Alyeska Theme 2.0.1

    Jason Bobich

    Yeah, sure you can just update to the latest version. Just download the latest version of the theme from ThemeForest, and upload it to your site, replacing the previous version you have. Going from v2 to v3, these are the instructions you want to follow:

    … The main thing to note (discussed in that article) is that a lot of the functionality, that used to be located within your theme, is now located within plugins that you need to install. But as it shows in that article, when you update the theme, you’ll be prompted to install all the plugins, which should take just a few minutes.

    And your child theme doesn’t contain any kind of framework or anything; it’s just your customizations. So, you don’t need to change anything in your child theme, unless after you update, you see that some of the customizations you’ve made no longer work right.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.