This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Tagged: 

portfolio plugin issue

  • Creator
    Topic
  • #13284
    nigdowser
    Participant

    I have set up a portfolio, named it and added items to it.
    I have also set up a custom layout where the portfolio will be displayed.
    The portfolio layout page shows the thumbnails and clickable link, but the link gives a 404 error.
    In fact, when I try to view any item in a the portfolio, I get the same 404 error.
    It is published and the visibility is set to public, yet I cannot view it.
    What have I missed out on?
    I’ve checked the settings in the Theme Options, but nothing obvious there.

    Thanks

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #13295
    Jason Bobich
    Keymaster

    Hello,

    Try going to Settings > Permalinks and re-saving your current permalink settings. Does this solve the issue?

    #13306
    nigdowser
    Participant

    Sadly, no.

    I can get the posts to show using the paginated grid in the builder and pulling them from a category and they show up fine there.

    Should the URL (using the Portfolio) have domainname.com/item/postname, rather than domainname/postname?

    Thanks

    #13311
    Jason Bobich
    Keymaster

    An individual portfolio item post would be at:

    http://domainname.com/item/postname

    A portfolio archive would be at:

    http://domainname.com/items/portfolio-name/

    A portfolio tag archive would be at:

    http://domainname.com/item-tag/tag-name/

    I’m guessing this is just a simple permalinks setup issue with your site, and so first I would start with a little more troubleshooting there to see if that’s where your issue is. To star, go to Settings > Permalinks, and turn permalinks off all together (i.e. change the setting to “default”).

    Does the issue go away? — If it does, then you know the problem is something to do with how you’re setting up your permalinks or possibly a conflict with something else in your site (a plugin or something) that uses the same structure. If the issues doesn’t go away by turning off permalinks, then show me a link to the issue and we can explore other options.

    #13358
    nigdowser
    Participant

    Yes, the issue goes away…thanks for catching that. So, what’s the next step? I like the permalinks the way they were….. 🙁

    #13381
    Jason Bobich
    Keymaster

    In all honesty, I’m not sure of the answer to that. There is nothing custom at all about the way we’ve implemented this. This is simply standard registered post types.

    How are you actually setting up your permalinks? Have you played around with different ways to set them up to experiment? It may be worth a post over at wordpress.org forums, as well, to see if there’s a workaround just for how you’re setting up permalinks and using custom post types in general.

    #13383
    nigdowser
    Participant

    Thanks, Jason. I’ll see what I can come up with.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.