This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

No More Visual Editor with WP 3.5 :

  • Creator
  • #2154

    Dear Jason,
    There are a few people reporting this in the WP support forums, in French also, โ€“ no one seems to have an answer โ€“ so maybe you’ll find THE solution.
    My web site :
    WP 3.5 and AKITA 1.1.5
    Plugin installed :
    -All in one favicon
    – Contact Form 7
    – Google Translator
    – Theme Blvd Featured Videos
    – Theme Blvd News Scroller Widget
    – Theme Blvd Post-to-Page Link
    – Theme Blvd String Swap
    – WordPress Database Backup
    – WP-Table Reloaded
    The Bridge and WPML are installed but not yet activated. (I’m working on a proper English version not fan of google translate !)

    When editing or modifying a post by clicking on the โ€˜visualโ€™ tab the window is empty white.
    However, It’s working with the HTLM.

    I’ve already tried the following steps, but NOTHING works ! :
    – Uninstalled and then re-installed all the plug ins.
    – Manually Cleaned the cache & cookies
    – Tried on Firefox and Chrome so it is not a browser issue.
    – Switched to Twenty Eleven theme and back to my current theme
    then one other solution found on the French forums
    – Install Use Google Libraries + Wp Super Edit with a wp-config.php file with the define language changer in en_EN instead of fr_FR

    So, I went back to the “normal”, still with the issue.

    2 Last Details maybe helpful for your diagnostic :
    – Below the editing post window, there is the Warming red banner “There is an autosave of this post that is more recent than the version below. View the autosave”. Never seen that before when using the previous version.

    – when I was trying plugin Super Edit, I got this warming message as well :
    “Warning: Missing argument 2 for wpdb::prepare(), called in /homez.625/balibert/www/wp-content/plugins/wp-super-edit/wp-super-edit.core.class.php on line 114 and defined in /homez.625/balibert/www/wp-includes/wp-db.php on line 990

    Hope you’ve already solved the probleme for somebody else !

    Thanks a lot,
    Miss (frenchie) Alice

Viewing 15 replies - 1 through 15 (of 19 total)
  • Author
  • #2157

    To go furhter,
    I’ve done a Diagnose JavaScript Errors on FF :
    – SCRIPT_DEBUG : the error is not fixed
    – DIAGNOSIS the JavaScript error, with the error consol :
    See the sreen shot on
    (“data no understandable from the element of the document”)

    Any idea ?

    Thanks a lot
    Miss ALice

    Jason Bobich

    All of those plugins giving you errors, I’d try disabling them. Notice in your Warnings/Errors how they list a filepath. All of those correspond to a certain plugin.

    For example, this:

    Warning: Missing argument 2 for wpdb::prepare(), called in /homez.625/balibert/www/wp-content/plugins/wp-super-edit/wp-super-edit.core.class.php on line 114 and defined in /homez.625/balibert/www/wp-includes/wp-db.php on line 990

    … this would coorespond to whatever plugin you have in the folder called “wp-super-edit” — Most likely a plugin called something like “WP Super Edit”. So first try disabling those plugins that are giving you the errors and see if that helps.


    Dear Jason,
    Thanks. Maybe I wasn’t very clear : I ALREADY CHECK without ANY PLUGIN.
    The error seems coming from the JS directory :
    js/tinymce/tiny_mce.js?ver=358-23156 line 1

    Any idea how i can fix this tiny_mce.js file ?


    Jason Bobich

    I haven’t run into this myself, but I can check it out for you. If you want that, shoot me a login to your WP admin. You can send me the info through My Account > Submit Private Info here are on the support website.


    Dear Jason,
    I’ve just sent you a login on the private way.
    Waiting for your news..

    Jason Bobich

    Ok, so I’ve seen this before. It’s rare, but it happens. Your server is generating an internal server error from the theme’s shortcode generator. Specifically, it’s this file:


    It’s impossible to know for sure without having access to your server’s error log, but most likely it’s a mod_security issue. This is an extension of Apache that some hosts have setup more restrictive than others. I have a feeling this is what it is. Just contact your webhost, tell them that file is generating an Internal Server error always on your server, and they’ll be able to see why and most likely fix it.


    Dear Jason,
    Thanks for your answer.
    Indeed, I’ve checked the Error log file, which includes a “Premature end of script headers: editor_plugin.php “.
    Is this file that one in the Akita theme file/framework/shortcode/tynimce/shortcode/editor_plugin.php ?
    What i DO not understand is WHY, the visual editor is NOW OK on Safari 5.0.5 but NOT on the 5.0.6 (with same preferences & security). What does have Safari 5.0.5 special ?
    Still not working on FF, neither Chrome.
    Waiting for your point of view,
    Thanks a lot
    (I’ve sent the request to my webhost, stll waiting for their answer).


    Dear Jason,
    My webhost answered me that the permissions of my AKITA THEME FILE in wp-content was in 777 and that I had to change it 755. The conflict with the Apache server came from that.
    I did it and you know what : THE PROBLEM IS SOLVED ! Visual editor on WP is back.
    I was visibly to much permissive ๐Ÿ˜‰
    Thank you very MUCH for your help & investigation.
    Take care,
    We all need you (and your team)
    Miss frenchie Alice

    Jason Bobich

    Great, glad you figured it out. And thank you for telling me what your host said. Noone has ever told me that one before, but it makes sense.


    Could you please tell me which ‘AKITA THEME FILE in wp-content’ it was that you changed the permission to 755 on? my site is having exactly the same problem and doesn’t seem to be connected to a plugin. it worked before i upgraded the site to WordPress 3.5.

    Many Thanks.

    Jason Bobich

    @nornironlegend This all depends on your host. If you are having this same issue with this file, you may want to contact them for advice.


    I have a feeling @missalice has a similar server setup as mine. On my server, for security reasons, I can’t have certain files set as 777. So, there is literally nothing on my server or in my WordPress installation that has permissions 777. All directories are 755 and files are 644. This is actually what WordPress sets up by default (I believe) when you’re working with files through your WP admin (i.e. plugin updates, core updates, installing themes, etc).

    Jason Bobich

    I have a question for both of you, if you don’t mind.

    When you installed the theme, did you upload the file through your WordPress admin panel? Or did you upload the theme in some other way? Like through FTP, your host’s cPanel, etc?


    Tried that and still no luck with mine.. The tab is still greyed out.

    I installed via the WordPress panel and using the child theme.

    Jason Bobich

    I saw someone else that a similar issue and it turned out to have nothing to do with the theme. ( — to which I still do not know why this is happening to them, but none the less started for them after updating to WP 3.5 no matter what theme they have activated. Most likely if you’re having this issue and it were theme related, I think it would have been happening before you updated to WP 3.5, as well.

    Have you tried activating Twenty Twelve temporarily to see if the problem goes away or not? You won’t lose any theme settings by doing this.

    [edit] Searching on forums, this seems to be a huge thing that many people are facing after updating to WP 3.5.


    Just switched to Twenty Twelve theme and your right… still the same problem!! Must be a bug in 3.5…

    Thanks for looking into it for me anyway… hope i get it sorted ASAP!

    Client isn’t too happy but certainly isn’t a reflection of your theme!

Viewing 15 replies - 1 through 15 (of 19 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.