This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Layouts to Posts May Not be Working Properly – Barely Corporate 4.1.8

  • Creator
  • #21797

    Some of our posts that we apply custom layouts to work just fine. They pull up the sliders and other content before the current page widget. Newly created posts do not recognize widgets added to the featured above section.

    What would be holding us back and what do we need to do to solve this issue?


Viewing 15 replies - 1 through 15 (of 31 total)
  • Author
  • #21798
    Participant is the website. is using a new page tempalte (exactly matching the old version)
    and here is a page with working page template, where all looks the same:



    I am very happy to provide you with the login for the site and show you the problems we are encountering.

    For instance, this is a post using a template. You can’t click on the post links or most of the images. Not sure why one or two work but the rest do not.

    The other issues deal with the pages above (last mssg) and trying to setup/utilize new page templates. It seems that the featured sections are being ignored when selecting a page template for a post.

    Let me know what you need from me to get this sorted. Thanks for everything!

    Jason Bobich


    Are you using some kind of caching plugin to optimize your site?


    No, not other than wpengine.

    Jason Bobich

    You can’t click on the post links or most of the images.

    Let’s start with this. It looks like you’re using the theme’s post grid, and I assume this is where you’re referring to with this.

    Now, most of the featured images here don’t appear to be setup with an image link. I assume you at this point you know how to set the featured image link for an individual post?

    So, if you’re changing this setting for the posts, and it isn’t being reflected when you view your site, this is why I ask if you have some sort of caching going on. It’s not possible for this to have anything to do with the fact that’s it’s a custom layout.


    Yes, and the default is to use the image link. I loved that feature and use it religiously.

    But its weird too b/c the h1 of the posts are not links either. Why would the html be removed? Is this just my browser(s) that this is happening?

    There are no other caching plugins in here, unless something is doing it rouge, but I am pretty inline with all of my plugs. It’s hard for me to tell when all this started happening, but I know its been happening since I updated the themeblvd plugins. I just updated the pareent theme the page few days.

    Let me know where to go. I really appreciate your help.


    I have it set as default to use image link to post, and I have it set on every property page.

    The other problem is that we use the same page layout to do new properties, and its ignoring the featured section. As far as I can tell, all of these are setup the exact same also. Just the one’s not working were most likely setup after the update.

    Jason Bobich

    It looks like you’re doing quite a bit from your child theme. Have you tried disabling your child theme, activating the parent theme temporarily, and verifying all of these same issues? This way ,we can rule out anything in your child theme that might be interfering.


    I did, its super jacked up now -styling wise. trying to fix


    it doesn’t look that any of the settings saved or crossed over to parent theme.
    I will give you access if you want to investigate. I am more than happy to do something for your time.


    Jason Bobich

    Yes, theme options are saved based on the name of the current theme; so these will not be there any more if you switch to the a theme with different name (i.e. the parent theme in this case). But this doesn’t matter, as we’re trying to troubleshoot the other issues you’ve been discussing. Don’t worry, when you switch back to your child theme, all options will be there again.

    So, after activating the parent theme:

    1) When you look at a post with custom layout, where before the featured area wasn’t being outputted, does it now output? Or do you have the same problem with this?

    2) Go to your theme options (I assume you’re using this plugin) and save the option again that sets all featured images to automatically link to their posts.

    Now, revisit the page where you put the post grid, and does the functionality you said didn’t work before, still not work?


    Hey J,
    Here’s my synopsis:

    #1) The site is completely blank. There is no page content on that page, nor anywhere else on the website.

    #1.5) None of the options are saved from before. Nothing is set right, but I can’t see the live pages, so….

    #2) I can’t do anything because none of the options are saved. I see all of wp-admin but none of the live website pages.

    Does this help? Sorry,….


    There is content if you scroll way down the page. The content is there, the structure is not.

    no the featured section does not show on this page either.

    on all pages, the menu is not showing.

    I can go through and save the theme settings, save what homepage, etc. etc. and nothing fixes it at all. I’m going to switch site back to my child so it looks ok.

    I am not controlling all of this through my child theme. I have not overwritten anything from the parent that would cause issues like this. I’ve never seen this type of issue before and I’ve wiped all the theme settings once or thrice moving your themes from server to server (domain to domain anyways).

    Let me know your thoughts.

    Jason Bobich

    1) Yes, menus, widgets and theme options are saved based on the theme, but aside from that, it doesn’t make sense that the entire site would just be broken by activating the parent theme — so this has me questioning if the parent theme is present in its entirety and uploaded properly.

    2) Does your child theme contain the file content-grid.php?

    3) Can you share your child theme’s functions.php with me?

    4) Did all of this just start happening after you made a theme update? If so, what version of Barely Corporate were you updating from?


    1) Yes I even went back and uploaded the full parent again.

    2) I sent private – answer is no
    3) I sent private
    4) it may have been happening before, but I think the last was 4.1.5 to 4.1.8

    I think this is correct. It was noticed the same time that the blue background in the header came through for everyone. Crazy stuff started happening then…

Viewing 15 replies - 1 through 15 (of 31 total)
  • The forum ‘Barely Corporate Responsive WordPress Theme’ is closed to new topics and replies.