This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.


Jump Start 2.0 Beta #2, Merry Christmas!

  • Creator
  • #19829
    Jason Bobich

    About a month ago, I posted Jump Start 2.0-beta1, and now it’s time for v2.0-beta2. You’ll find this second beta now available in your account’s Downloads section.

    This update primarily caters to the non-developer user experience, adding two new theme bases, and improving options in the Super User theme base.


    Here’s the full changelog going from v2.0-beta1 to v2.0-beta2… mostly just little bug fixes and minor additions.

    • Added two new theme bases; see Appearance > Theme Base.
    • Added system to check if saved theme options match selected theme base.
    • Added “Custom CSS” option utilizing code editor to all theme bases (except Developer).
    • Added editor stylesheet for editing posts and pages.
    • Added unique HTML ID’s to sections of custom layouts like page-slug-section-1.
    • Added Portfolios plugin to recommended plugins when installing theme.
    • Added integration for FontAwesome icons in header text option by using
      %name-of-icon%. (See screenshots)
    • Expanded options for divider component.
    • Fixed responsiveness of Promo Box element.
    • Fixed issues with new Footer Sync feature and using Columns element. Make sure to update Layout Builder plugin to v2.0.2, also.
    • Fixed “color” value of “typography” option type.
    • Fixed Google fonts not getting applied, when set from Theme Options page.
    • Fixed bug with not being able to apply background color opacity to display options for columns in the Columns element.
    • Various little fixes and enhancements to Super User theme base and selecting various options.
    • Fixed bug where controls of Gallery post slider moves entire outer post grid slider.
    • Fixed admin bar for logged-in user, viewing site on mobile.
    • Fixed “Column Height” force of Columns element, in Firefox.
    • Fixed issues with main menu “plus” icons showing when activating a plugin that adds FontAwesome.
    • Fixed issues with “No, don’t apply featured image link to single post” in post options.
    • Fixed Post Showcase page template pulling crop size for Post Grids.
    • Fixed fatal error with WooCommerce.
    • Little fixes to WPML compatibility.
    • When header top bar is empty, it will not display (i.e. no header text, social icons, or searchform set to show). Except with Entrepreneur base, will be hidden if there’s no header text.
    • Primary Navigation no longer has HTML ID “tb-primary-menu” and instead has the class “tb-primary-menu” — Take this into account if you were using #tb-primary-menu to do any custom menu styling, and instead now use .tb-primary-menu.
    • On small mobile devices (480px and below), all buttons .btn are now styled as block-level elements.


    A couple of our little plugins have been updated to work with the Jump Start 2.0.

    1. Portfolios — Incorporate a portfolio item custom post type
    2. Theme Blvd Layouts to Posts — Apply custom template from Builder to posts

    If you’ve found other little Theme Blvd plugins that are not working, just let us know and I can add them to the list. Theme Blvd Image Sizes is still on the to-do list.

Viewing 15 replies - 1 through 15 (of 31 total)
  • Author
  • #19836

    Did the markup for the primary menu get changed in this release or did I just miss it last time around?

    Jason Bobich

    Did the markup for the primary menu get changed in this release or did I just miss it last time around?

    @johnnya23 Yeah, the major thing that changed is that the menu no longer has the ID “tb-primary-menu” but instead has the class “tb-primary-menu” … So if you were styling with #tb-primary-menu, you need to change to .tb-primary-menu.


    Christmas and New Year joy. Thank you Sir.

    Zoe Snyder

    I just completed a 2nd fresh install of this latest version, 2.0 Beta#2, and I discovered there is no Theme License option under Appearance.

    I also had the “Saved options don’t match theme base” error, and got that cleared up with instructions from another post, ( hoping that would address the license option as didn’t.
    What could be the reason for license option not appearing?


    Jason Bobich

    What could be the reason for license option not appearing?

    @zoe Apologizes for any confusion, but I have purposely disabled this admin page because currently it doesn’t apply to the Jump Start beta. I haven’t figured out how licensing and sale of Jump Start v2 is going to work, exactly.

    Wendell Harness

    First of all, I just want to say that I love the new WPJS! I’ve tried desperately to find anything “wrong” with it, so I could report back to you with my findings. However, you are so good that I could only find one problem so far:

    The social icons at the top tend to flip out when you hover on them. You can see what I mean at a work-in-progress site at — note that it is using the Pro base.

    Jason Bobich

    @harnesstech Hi, thanks for the kind words! When I hover over your icons, some little piece of markup is getting added with javascript (which is not part of the theme). So, I’m thinking one of the plugins you’re using is causing some sort of effect there. Try going through what you have installed.


    Just a small note Jason.

    In Templates and using the Columns element with Popout / Stretch applied.
    If you do not have a background applied to a ‘column display’ this will add a horizontal scrollbar in the browser window because the class ‘row’ style: margin-left/right is not set to 0.

    <div id="element" class="element element-columns popout stack-md clearfix" style="">
    <div class="row" style="margin: 0 -15px 0 -15px;">
    Jason Bobich

    @mizzinc Thanks, will get that fixed.

    Wendell Harness

    When creating a new template using the Stats sample layout, I cannot save updates. I get the spinning icon next to the update button and it never saves. I tried deleting the template and creating a new one, but still the same issue. I also tested to make sure I could save other templates and had no trouble with those. Further, I also tried saving in other browsers and they all have the same problem.

    Also, I have a very barebones install for this one, having only WPJS2b2, the recommended plugins and the standard child theme.


    Thanks @themeblvd

    Also, how do you apply an overall stretch layout?

    Im targeting ‘.site-inner > .wrap’ by removing max-width etc. But receive the horizontal scroll bar again.

    Jason Bobich

    @harnesstech It’s probably some sort of issue that is specific to your server. Did you try looking at the Console tab in either Google Chrome inspector or Firebug when you save? And see if there’s an error?

    @mizzinc Spunds like the same issue as you just pointed out with the colums pop out? The main sidebar layout of theme uses Bootstrap row of colums also, which has -15px of margin on both sides. So if this edge is hugging the edge of the browser window you need to have 15px of padding to counter and bring the alignment to 0.

    Wendell Harness

    Thanks Jason. Here’s a screen shot. There seems to be some “not found” errors.

    Jason Bobich

    Yeah something on your server is blocking WordPress’s Ajax request, with it not liking something about that specific accumulation of data.

    It may be a mod_security issue (I’ve seen this in the past, just no in awhile)? You can contact your web host and explain that it looks like there’s some sort of security flag being triggered when you try to submit this data through Ajax. They can check your server’s error logs, to see what it is. If they can see an error, they can most likely adjust your account setting to fix.

    Wendell Harness

    Quick update: turning off mod_sec didn’t stop the problem. But we did notice that we get an error even when just loading the template edit page:

    GET 404 (Not Found)

    Coincidentally, on any templates with a slider, the last image in the list of slides is broken and the filename is shown as “f”, which seems to coincide with the error, oddly enough. To clarify, the “f” filename problem happens when creating a new template based on a sample layout with an image slider.

    Anyway, there’s a guy working on the hosting account to see if he can find the problem.

Viewing 15 replies - 1 through 15 (of 31 total)
  • You must be logged in to reply to this topic.