This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Hero unit text blocks invisible

  • Creator
    Topic
  • #23990
    Erik Almén
    Participant

    Hi Jason.
    There’s something weird with the hero unit slider. I’ve put av video background on one and the text blocks looked fine. But when I turned off the background shading the text blocks and the button dissapeared. When I turn on the shading they appear again. Here’s the site – http://u1984054.fsdata.se/dog/

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #23996
    Jason Bobich
    Keymaster

    Hi,

    Try adding this to your child theme style.css:

    .tb-jumbotron {
      position: relative;
      z-index: 2;
    }

    I will look more into why this specific combination of configuration options has this effect, for the next update.

    #24024
    Erik Almén
    Participant

    Hi,

    I tried but no success unfortunately. I’ve put a 10% shading on it for now. Let me know if you find a solution. Thank you!

    #24027
    Jason Bobich
    Keymaster

    Would you mind taking off then shading and putting the CSS in there so I can see?

    #24033
    Erik Almén
    Participant

    No problem.
    CSS on and no shading now – http://u1984054.fsdata.se/dog/

    #24034
    Jason Bobich
    Keymaster

    Try it like this instead, styling the wrapping .jumbotron-wrap element. That should be contained within the same level of the markup tree as the video, to z-index it above.

    .jumbotron-wrap {
        position: relative;
        z-index: 2;
    }
    #24068
    Erik Almén
    Participant

    Works perfect. Thank You!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.