This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Dropdown Menu missing

  • Creator
    Topic
  • #16387
    xanderusa
    Participant

    Hi, I recently bought this Alyeska theme and looks wonderful; however, the dropdown menu (sub itmes: Homestead, Hello word, FAQ ) are not appearing in the top menu but in a kind of “shadow” without linking (pointer not appearing) when highlighting the menu. It looks like the white stripe is covering it, but I am not sure.

    I am attaching a pic.

    http://s2.subirimagenes.com/imagen/previo/thump_8880871menu-wordpress.png

    My site is this http://www.shorttermrentalsinmiami.com

    Also, I noticed this plugin (Theme Blvd Shortcodes) was putting in blank everything, so I deactivated. I am not sure if the dropdown menu is related to this issue. The other thing is that I got this note on the top: “You currently have the “Theme Blvd Widget Pack” plugin activated, however you are not using a theme with Theme Blvd Framework v2.2+, and so this plugin will not do anything”

    Could you help me please? Thank you

Viewing 15 replies - 16 through 30 (of 35 total)
  • Author
    Replies
  • #16488
    xanderusa
    Participant

    Hi Jason.. the problem is that the theme is working perfect on MAC’s users but PC’s. .
    Check testing pic:
    https://drive.google.com/file/d/0B2Q1_6eemgpZdTQtZG5SaUNjQlE/edit?usp=sharing

    Tested with this site to check how it looks on MAC’s. http://url2png.com/?via=icapture

    Also I made this CCS validation..( I don’t get a clue of it) and this is what I got:

    http://jigsaw.w3.org/css-validator/validator?uri=http%3A%2F%2Fshorttermrentalsinmiami.com&profile=css3&usermedium=all&warning=1&vextwarning=&lang=en

    Even though I made a video again so you can tell me what I am doing wrong in the process.

    https://www.youtube.com/watch?v=WsqOAubQj0Q

    Ty πŸ˜‰

    #16490
    Jason Bobich
    Keymaster

    I see now. There has to be something unique in your site that’s causing this reaction in IE. You need to start going through customizations you’ve made via plugins and Custom CSS.

    One possible idea. — Do you have some sort of plugin installed to edit CSS? What is this from?

    <style type="text/css">PICK AN ELEMENT NOW - or type CSS selector(advanced) {
    font-size: 30px !important;
    color: #444 !important;
    }
    PICK ELEMENT FIRST! {
    font-size: 20px !important;
    color: #222 !important;
    }
    </style>

    That’s a block of totally invalid CSS. I could see how something like that would break IE.

    #16493
    xanderusa
    Participant

    I don’t have any idea Jason. I don’t know anything about customizing CSS nor plugins. A disabled all plugins just to see if something was blocking the theme but don’t. This is the list of plugins.

    Akismet
    Black Studio Touch Dropdown Menu
    Broken Link Checker
    cbnet Ping Optimizer
    Comprehensive Google Map Plugin
    Contact Form 7
    Easy Modal
    Facebook Comments
    Font
    GC Testimonials
    POWr Social Media Icons
    Theme Blvd Image Sizes
    Theme Blvd Layout Builder
    Theme Blvd Shortcodes
    Theme Blvd Sliders
    Theme Blvd Widget Areas
    Theme Blvd Widget Pack
    Theme My Login (inactive)
    Tweeple
    WordPress SEO
    WP e-Commerce
    WP e-Commerce Grid View LITE
    WP Sliding Login | Register Panel (inactive)

    WP e-Commerce: and when I deactive this one it generates this. So I am not sure is this related something to the CSS or what..
    Fatal error: Call to undefined function is_products_page() in /home3/ctaveras/public_html/shorttermrentalsinmiami.com/wp-content/plugins/wp-e-commerce-grid-view/classes/class-wpsc-gridview-hook-filter.php on line 35

    #16510
    Jason Bobich
    Keymaster

    Well, when all else fails, you can do what I’m about to do. πŸ˜‰

    http://lmgtfy.com/?q=β€œPICK+AN+ELEMENT+NOW”+plugin

    … Looks like that snippet I referenced above is from the plugin “Font” from your list. Try disabling that and see if it fixes your background issue.

    #16521
    xanderusa
    Participant

    Didn’t work. I had disabled all plugins one by one all the same. πŸ™

    #16523
    Jason Bobich
    Keymaster

    All right, let’s see if we can get to the bottom of this. Can you disable every third-party plugin on your website, and then post back here so I can look at the site again?

    #16524
    xanderusa
    Participant

    Every plugin is disabled now.. πŸ™‚

    #16530
    Jason Bobich
    Keymaster

    This is one of the weirder things I have seen. I know this all confusing for you, but please try to read closely, as your problem is actually bigger than just that the custom background won’t show. You need to understand the issue so you can seek further help from your hosting provider.

    If you look in header.php of the theme (the template file in any WordPress theme that shows the top of the website), you’ll see where the opening <body> is setup like in every WordPress theme:

    <body <?php body_class(); ?>>

    body_class() is a WordPress core function that outputs all of the classes on the body tag when your site loads. So, the above should produce this, if you were to view source on the frontend of your site. (You can see this working properly if you view your site in Chrome, Firefox, etc.)

    <body class="class1 class2 etc">

    But in Internet Explorer only, this gets botched and always outputs like this, where you can see the class is missing.

    <body >

    So, my first question was, what is effecting (or breaking) WordPress’s body_class function? All plugins are disabled, I had the default theme that comes with WordPress activated at that point, and I verified your WP install is all up-to-date. Issue was still happening.

    Then I tried something that really threw me for a loop. I removed the body_class() function all together, and in the theme’s header.php, I physically typed out the following with no PHP functions involved at all.

    <body class="test">

    And when I looked at your site in IE, I saw this again:

    <body >

    Then, I did another experiment. I typed this into your header.php:

    <body class="test">
    <body class="test">

    And it got outputted like this:

    <body >
    <body class="test">

    There is absolutely nothing in the theme doing this. And there’s nothing in any plugin, or even WordPress itself that has the functionally to alter the HTML markup within these main template files once they’re included. The only explanation that I can even fathom, is that there is something on your web server that is effecting the output sent back to Internet Explorer. It is targeting the first instance of <body> on the page and removing the class… I guess?

    I have googled all around and have found absolutely nothing. I would contact your webhost and do your best to explain what’s happening, and see if they have any ideas.

    #16531
    Jason Bobich
    Keymaster

    By the way, if you’re wondering how this corresponds to your original issue… When you set a custom background, WordPress adds a class to your body tag called “custom-background” which it then utilizes output CSS applying that background. This is what has lead us to the bigger issue here. You need classes to be outputted on the body tag for a lot of different things.

    #16691
    xanderusa
    Participant

    Hi, after upgrading the theme it is still not working. I went for my Hostgator support and this is what they told me:

    (6:35:26pm)Justin A.:There wouldn’t be a server configuration that would enable one OS to show this but one would not. I do believe the theme is showing correctly for me so it works on Linux as well.
    (6:36:03pm)Cesar Taveras:yes I know but if you open it in a PC it is still in white
    (6:36:25pm)Cesar Taveras:the background in white*
    (6:40:24pm)Justin A.:One moment while I check on this for you.
    (6:40:33pm)Cesar Taveras:OK
    (6:43:58pm)Justin A.:Still checking in on this for you.
    (6:44:20pm)Cesar Taveras:sure
    (6:46:59pm)Justin A.:Okay, from what I am seeing there is no way the server would cause issues with one operating system but not another. This would be an issue with the configuration of the theme possibly not being compatible to be viewable by the PC OS.
    (6:47:30pm)Cesar Taveras:umm i see
    (6:48:07pm)Cesar Taveras:that’s so rare.. The vendor assures it’s not their config…
    (6:48:49pm)Cesar Taveras:what would you suggest me to check?
    (6:50:47pm)Justin A.:Unfortunately, I am not quite familiar with coding as I am not a developer, I have consulted with my colleagues to see if it is possibly a server issue and I was confirmed that generally all operating systems would be affected if that was the case.
    (6:51:17pm)Cesar Taveras:I see… well, thank you anyways

    πŸ™ pls help

    #16693
    Jason Bobich
    Keymaster

    I have no idea. I have thousands of customers and I’ve never heard of a such a thing. But your problem is not specific to this theme in any way, as you can tell by switching on default WordPress theme and seeing the same issue. Maybe try posting on wordpress.org forums?

    #16694
    Jason Bobich
    Keymaster
    #16697
    xanderusa
    Participant

    I did, but they told me they didn’t help since this theme already have its own support. lol but anyway, I just posted another different post just to see if I am lucky, and I’ll let u know. I even paid to a CSS in fiverr but he cancelled out the gig.. πŸ™

    Thank you

    #16698
    Jason Bobich
    Keymaster

    As I said, your problem is not theme related. So what you want to do when posting on wordpress.org is deactivate all plugins and activate a default WP theme. Then say look at my site in IE. Why on earth isn’t the body class outputting?

    #16699
    xanderusa
    Participant

    I just got this from someone but no idea how to validate my site.

    Have you tried checking for markup & CSS errors?
    http://codex.wordpress.org/Validating_a_Website

    Reply

Viewing 15 replies - 16 through 30 (of 35 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.