This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Demo is not importing

  • Creator
  • #23560

    I also have a problem importing the demo content of the denali theme.

    This is the error message:

    Sorry, there has been an error.
    This does not appear to be a WXR file, missing/invalid WXR version number

    I tried the following demo-1 files but they do not work, I only get the error message above:


    Am I doing something wrong? Usually I got only one demo-file to upload. Which is the one I have to use?
    Can you help me?

    Cheers Dirk

Viewing 15 replies - 1 through 15 (of 17 total)
  • Author
  • #23561
    Jason Bobich

    Hi Dirk,

    I think you’re misunderstanding what you’re supposed to be uploading. The files you’re referencing are part of theme, and you aren’t supposed to touch those.

    The file you want to import is called denali-demo-1.xml and is located in the “All files and documentation” zip you download from ThemeForest. It is a single file as you’d normally expect. After importing this has finished, the theme automatically uses those other three files to complete the setup process.

    Please watch the video tutorial on this from your documentation:


    Umpf! 😉
    You’re right!

    But now I get another error-message:

    Fatal error: Out of memory (allocated 63700992) (tried to allocate 4800 bytes) in /homepages/16/d595222962/htdocs/wp-includes/media.php on line 2130

    What now?

    Cheers, Dirk

    Jason Bobich

    You’ll just need to increase your memory limit for PHP, and you should be good to go. You can do this from the wp-config.php located in the root directory of your site where WordPress is installed.

    If this isn’t something you’ve ever done before, you can google something like “increase PHP memory limit wordpress” — And you’ll find some video tutorials and what not.


    Hi Jason,
    thanks for the quick reply.
    Ok, I’ve inreased the memory limit to 256mb but importing the xml file seems to do nothing.
    I only get the message:

    Importiere WordPress
    Medien “dwight” existiert bereits.
    Medien “jumpstart-zip-hoodie-1” existiert bereits.
    Medien “jumpstart-zip-hoodie-2” existiert bereits.
    Medien “jumpstart-zip-hoodie-3” existiert bereits.
    Medien “jumpstart-zip-hoodie-4” existiert bereits.

    But nothing else happens. How long does the import take? There is no message that all is done?

    Best regards, Dirk


    BTW I also increased the max file upload size to 32mb


    So, now when I delete the above mentioned files “jumpstart-zip-hoodie-1” etc. there’s no error message at all.
    The importer says “importing wordpress” but nothing happens. Only the files above are imported again.

    I also tried one of the other demos with no success. Same result – nothing is imported.

    I also tried to zip the xml file to a “denali-demo-1.xml.gz”, the importer recognises the file but imports nothing.

    Exporting a little xml file with two articles works fine an the import of the exported file works too.

    I really do not know what to do else. Any advice?? Please help.

    Best regards, Dirk

    Jason Bobich

    It can take awhile depending on your setup. I did one the other day for someone and it took about 15 min doing the big default one, demo #1. If your browser hasn’t stopped loading, then that means it’s still going.

    Send me a login to your WP admin if you want and I can try and do it for you.

    Jason Bobich

    I just tried to do the import on your site, and I’m having the same memory issue.

    Fatal error: Out of memory (allocated 68943872) (tried to allocate 4800 bytes) in /xxx/htdocs/wp-includes/media.php on line 2130

    Are you sure you’ve increased it? That doesn’t seem possible if you’ve set the limit to 256mb. Are you sure you put the following exact line in your wp-config.php?

    define( 'WP_MEMORY_LIMIT', '256M' );
    • This reply was modified 7 years, 7 months ago by Jason Bobich. Reason: Oops, I meant to write "WP_MEMORY_LIMIT"

    That’s pretty spooky.

    If you have a look in the dashboard, I’ve increased the limit and installed two plugins to control it. You will find them
    in the dashboard under “memory overview” and “wordpress system health”

    Jason Bobich

    Also, a note from the WordPress codex:

    Please note, this setting may not work if your host does not allow for increasing the PHP memory limit–in that event, contact your host to increase the PHP memory limit. Also, note that many hosts set the PHP limit at 8MB.

    In terms of importing this XML, we’re not talking about the theme any more, really. We’re just talking about you using WordPress on your server and running the WordPress importer. Your host can probably help you with this if you still can’t get it to import after you know you’ve increased the limit in your wp-config.php.


    Both addons are saying its at 256mb.
    After adding this line “define( ‘WP_MEMORY_LIMIT’, ‘256M’ );” to the wp-config.php the error message didn’t appear again.

    Jason Bobich

    I’ve tried about five times and keep getting this:

    Jason Bobich

    It could be that your WP System Health plugin just looks at the constant in your wp-config.php to tell you the memory limit, but your host is blocking the ability for you to change it.

    In other words, even though the WP System Health plugin is telling us it’s 256MB, this doesn’t actually appear to be correct. Contacting your web host will probably be your best bet at this point.


    ok, I will check this out first. Thanks a lot for your help


    Works fine now! 😉

Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.