This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Compatible with The Events Calendar? / Invalid Layout ID

  • Creator
    Topic
  • #17174
    relish27
    Participant

    Hello,

    I’ve inherited a site that uses this theme and am hoping to implement Modern Tribe’s The Events Calendar PRO (http://tri.be/shop/wordpress-events-calendar-pro/) in it. However, when I do the regular install of that plugin, the events page (which uses one of their templates) gives me this error: “Invalid Layout ID”

    Do you know if this theme is compatible with this plugin (which is fairly popular and well-regarded)? If so, is there a workaround for this?

    Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Author
    Replies
  • #17175
    relish27
    Participant

    I see Scot on the thread below had luck with Events Calendar… Would love to get some details! Because I *am* having issue!

    http://support.themeblvd.com/forums/topic/calendars-for-jumpstart-and-themeblvd/

    #17184
    relish27
    Participant

    Would love to get some help on this! I checked with Modern Tribe and they weren’t familiar with integrating their plugin in this framework…

    #17185
    Jason Bobich
    Keymaster

    Hello,

    Can you please provide a link to your site so I can see the issue? Specifically a link to where this issue exists? It doesn’t quite make sense that the plugin itself could be triggering the custom layout template. You’ve most likely inadvertently applied the custom layout template to the page the plugin is using, without realizing.

    #17191
    relish27
    Participant

    Here’s the link: http://www.epi.umn.edu/mch/events-calendar-new/

    When you install the Events Calendar, you just dictate the slug for the event location (the root of the site is at http://www.epi.umn.edu/mch/) so all I did was give it “events-calendar-new.” I didn’t create a page for it.

    #17194
    Jason Bobich
    Keymaster

    Aww, you’re using a super old version of the theme from January, 2012. You really need to be up-to-date for me to provide much help on this.

    We’re now on Alyeska 3.1, and in moving towards 3.0, and separating the layout builder to its plugin, we’ve changed so much how custom layouts are actually applied internally.

    If I remember right, I’m pretty sure your version has the option at Appearance > Theme Options > Content > Homepage we still use today (even though it now works much differently behind the scenes). The only thing that comes to mind that would correspond to the issue you’re having is that you inadvertently selected to show a custom layout in this homepage option and it’s getting carried through to the Events Calendar plugin page.

    I say “inadvertently” because you’ve currently got a static frontpage with custom layout set right now. So this option is not how you’ve chosen to setup your homepage, and thus should be set to “Posts” — or similar; I can’t remember if the wording of the selection is different now, but should be configured something like this, in your case.

    =======

    I would really suggest setting up a staging environment for your website and getting your self up-to-date with the theme. It may be a bit of a task to do this because you’ve fallen so far behind, but this will make life much easier going forward, and it’ll be easier for you to get support and have a product that continues to work with the latest WordPress.

    I see some personal code customization on your site, and since you’re not using a child theme, hopefully these modifications have been via a plugin you’ve created. But if you have made these customizations directly to theme files, you’ll really want to make sure when you update, you do these customizations properly from a child theme.

    Here’s the updated demo if you want to view:

    http://demoblvd.com/themes/alyeska/

    Here’s the changelog of everything that changed (specifically see 3.0.0, which is your main concern):

    http://themeblvd.com/changelog?theme=alyeska

    And here’s an outline you can skim that outlines everything you need to be aware of that is different in the way the theme works:

    http://support.themeblvd.com/updating-to-framework-v2-3/

    Here’s a video that will walk you through the basics of updating a WordPress theme:

    https://vimeo.com/41533135

    And then moving forward from this update, you can setup updates to stream through your WordPress admin:

    http://support.themeblvd.com/docs/theme-updates/#themeforest

    You can also see a list of release dates for all versions published to ThemeForest over time by looking at the “Changelog” at the bottom of the page here:

    http://themeforest.net/item/alyeska-responsive-wordpress-theme/164366

    #17196
    relish27
    Participant

    Thanks for the in-depth reply. Unfortunately, I inherited this site and only started working on it a few weeks ago. I’m a bit hesitant to upgrade because, despite the warnings, I can see the previous developer edited some if the default templates. In desparation yesterday I started doing the same — seemed the only way to create a page where I could put some if the MT code and dis play upcoming events. I guess I’ll have to weigh the short-term option s. — long term I agree getting up to date would be wise.

    #17199
    Jason Bobich
    Keymaster

    Yeah, that’s why I say get the site into some sort of staging environment where you can freely work on it before the updates ever get posted live.

    But first try looking at that option I mentioned at Appearance > Theme Options > Content. Does setting that to “posts” fix the issue?

    #17203
    relish27
    Participant

    Hi, Jason.

    In Appearance > Theme Options > Content I *do* see “Homepage content” set to “Custom Layout.” But that is because the home page is indeed a static page with custom layout. I wouldn’t want to change it to “Posts.” So, maybe I need to continue the hacky route for now and pursue an overhaul later on.

    #17205
    Jason Bobich
    Keymaster

    Ha no I’m telling you that the way you have your homepage setup, it should be set to “posts” — just trust me. That option is not what’s putting the homepage layout in your case. If you’d like clarification as to why, watch this video:

    https://vimeo.com/70256799

    #17210
    relish27
    Participant

    Okay, I get it. Makes sense. Given the deadline timing, I think I need to go the hacky route (unfortunately) for now (already live). But I fully understand that this is not the best long-term solution and will definitely make recommendations to rework this. Really appreciate the support today. Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.