This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Comments not appearing on static pages

  • Creator
  • #7689

    The “Comment” boxes appear at the ends of my posts. They don’t appear on any of my static pages. How do I make the comment boxes appear on static pages?

    When I switch to Twenty Twelve the comments boxes appear on the static pages. There’s something in Akita that’s hiding the comments on static pages.

    On each static page’s edit screen there’s a section for “Add comment.” If I add a comment to a static page, the comment is listed in my comments admin page and listed in the “Recent Comments” widget. The comment doesn’t appear on the static page.

    On “Screen Options” for a page (under the “Howdy…”) I’ve checked both “Discussion” and “Comments.”

    Under the “Discussion” box on a static page’s edit screen I have the boxes checked for “Allow comments” and “Allow trackbacks…”

    Under Settings > Discussion I have the box checked for “Allow people to post comments on new articles”.

    I deactivated each plug-in one by one. Nothing made comments appear.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
  • #7693
    Jason Bobich


    This is not possible from your WordPress admin panel, as this theme does not support comments on pages by default. However there is a way to do this by utilizing the framework’s filters in your custom code.

    Copy this into the functions.php file of your child theme:

    function activate_page_comments( $setup ) {
        $setup['comments']['pages'] = true;
        return $setup;
    add_filter( 'themeblvd_global_config', 'activate_page_comments' );

    To confirm, you’re saying that Akita was intentionally designed so that comments don’t appear on static pages? Maybe I should choose a different theme instead of changing code?

    After lunch I’m going to watch the video about child themes and see how to do what you said. I did what you said about changing the tagline font size so I want to change that in a child theme too.

    Jason Bobich

    Yes, this theme framework does not include the comments template by default within static pages. I do this because of many confused buyers I’ve had over the years of doing this. Most people are not using comments on pages.

    But realistically, I’ve built in this simple on/off for this. Simply paste that code into your Child theme’s functions.php, and comments will appear on your pages.

    This is the idea behind a Child theme, which is just a general WordPress concept. It’s a simple little theme that holds only your customizations, so you’re never actually making any edits to the code of the theme directly.


    Setting up a child theme was easy and everything works now. Thanks!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.