This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Can't Upload Theme

  • Creator
  • #2548

    I have a most unusual problem with uploading the theme on a Canadian Web Hosting company.

    When I first purchased the theme, I tried uploading it to my account at a Canadian Web Hosting company that I have used for years. ( I uploaded the zip file from the folder, not from the unzipped download.) It won’t load. WordPress times out after about 5 minutes and gives the error message “WordPress Failure, Are You Sure You Want to Do This?”

    I have been back and forth with the Canadian hosting company for several days. They have tried several work-arounds, to no avail. This is an excerpt from one of the messages I got from them – there have been several others since, all that have not been able to provide a solution. (I’ve xxx’d out the private info)

    Jan 7 21:40:32 cwhtor5 suhosin[121706]: ALERT – script tried to increase
    memory_limit to 268435456 bytes which is above the allowed value (attacker
    ‘’, file
    ‘/home/dxxx/public_html/’, line 109)

    In this case we will have to increase the suhosin memory limit to 512 MB. I have
    increased that in the “php.ini” file. I have pasted a screen-shot for your reference. You can verify this from the below mentioned link : etc.

    The hosting company went on to indicate that this would solve the problem. It didn’t. They have tried several other solutions and I still can’t upload the theme. I tried a fresh install of wordpress, set up a brand new computer just a few hours ago and tried again – no luck. Same error message as before.

    However, I upload the theme to my account at Hostgator. The theme uploaded perfectly and I am able to edit it and make changes, no problem.

    So, my question is, why will it upload on one server and not on the other, and is there anything the Canadian hosting company can do about it? In their last email they asked me to send the zipped version of the theme, plus my login info for the WordPress site I am trying to install it on. I am not about to do that.

    I’m concerned because I have several customer’s sites on the Canadian hosting company that I was hoping to get to purchase the Alyeska theme in order to upgrade their sites. If the theme won’t upload, it will be a lot of hassle to get these people to switch to another hosting provider.

    I have no problem at all with the theme on Hostgator. I guess that says something about the Canadian Hosting site, though I’m not sure what.

    Sorry for the long post, but it has been frustrating. If there is a work-around, I would appreciate knowing what it is, as I would sure like some of my customers to get this theme for their sites, which will not be possible if they can’t upload it, and I’m not sure any of them are prepared to change hosting companies.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Author
  • #2553
    Jason Bobich

    This is actually from the “Common Problems” section of the first “Getting Started” chapter of your documentation:

    Can’t upload theme

    Problem: When you try to upload through your WordPress dashboard in the way it’s described in the first installation video above and either it loads and loads with no result or you see the error message “Are you sure you want to do this?” followed by nothing happenning.

    Solution: Many of our themes may contain many options resulting in additional images, files, etc, making the theme’s overall file size larger than many other themes you might have used in the past. If you’re facing this issue, it’s most likely because your web hosting account has PHP upload limits in place that are smaller than the size of the theme. So, if this is the case, the solution is simply to unzip the theme and upload it manually through your FTP program. This process is outlined above in the second installation video.

    So, you just need to either increase your PHP file upload limit (which can also be done while you’re in that php.ini file) or just unzip it and upload the theme via FTP. Here’s that 2nd video from your docs that’ll show you how to do that:


    Jason: I did all of that and the theme still wouldn’t upload, which is why I posted the question here. I have been using WordPress for years and know how to manually unzip and upload the theme if the zipped zip file won’t load. I just wondered if there was something else with this particular hosting company that made it impossible to upload the file since the PHP upload limits were increased in the php.ini file.

    The solution for me will be to simply use Hostgator and gradually move all my files away from the other hosting company, and to encourage my customers to do likewise.

    Thanks again for the prompt response. I do watch all of your videos very carefully. They are excellent – easy to follow and understand. There is quite a large learning curve for this theme, but well worth the time it takes to learn the ins and outs!


    I am having the same problem. I’ve used Alyeska before with no problem but purchased it again for a client yesterday and it will not work. This is what the host team said to me:
    It appears this is being caused by a memory leak from your theme. We’ve tried upping the php memory but it continues to error out. All of the files appear to be in the correct place and pointing to the correct folders. The issue appears to be with your theme.


    Jason Bobich

    Have you tried increasing the Memory limit within your WordPress’s wp-config.php?


    I am not highly skilled at php code stuff. I usually just do the customizing work after the WP theme is successfully installed. As I’ve said, I first used Alyeska in June and that site worked (and still works) perfectly, no problem. But this time… The new site is with a different host. But just for kicks, I tried to install Alyeska on a new site with the same host I used back in June and it doesn’t work there either.

    I read the info at the link you suggested. I found this in the wp-settings.php file:
    // Set initial default constants including WP_MEMORY_LIMIT, WP_DEBUG, WP_CONTENT_DIR and WP_CACHE.
    wp_initial_constants( );

    and added this line:
    define(‘WP_MEMORY_LIMIT’, ’96M’);

    Then saved and uploaded it to the database, replacing the original. Is that correct?

    I couldn’t find any reference to memory in the wp-config.php file.

    Even with that change, I get this error when I try to go to my website page:
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20 bytes) in /var/www/html/wp-content/themes/alyeska/framework/widgets/tb-widget-contact.php on line 21

    And this at my wp-admin page:
    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 45 bytes) in /var/www/html/wp-content/themes/alyeska/framework/widgets/tb-widget-contact.php on line 15

    I’m admittedly over my head here. ???


    For what it’s worth – no matter what I tried, and no matter what the hosting company tried, (they even asked me to send them a zipped file of the theme, which I refused to do) I could not upload the theme to the hosting company mentioned above.

    My work-around was to open another account with Host Gator. The theme uploaded without a hitch.

    Jason Bobich

    @karlene You shouldn’t be ever editing any files of WordPress core. Your wp-config.php is the one file of WordPress core that you, the user, are intended to edit. It is the one and only hard file that contains the information that sets up your WordPress installation. When you installed WordPress you would have had to put your site’s information in here unless your web host provides some sort of “one-click” installation feature for WordPress or someone else did it for you.

    So, anyway, don’t touch wp-settings.php. Put it back the way it was and leave that alone. These edits don’t have anything to do with any databases.

    Here’s what you do:

    1. Access your server with your FTP program.
    2. In the root directory of your WordPress installation, there is a file called “wp-config.php” — Download this file.
    3. Open this file with a text editor to edit it on your computer.
    4. Anywhere in the file before where it says “That’s all, stop editing! Happy blogging,” put this:
      define('WP_MEMORY_LIMIT', '64M');
    5. Save the file and upload it back to your server.

    If you’re going to be managing WordPress sites, you really need to understand how to work with files on your server and the basics of setting up your wp-config.php file. So, this is a good exercise for you, either way.

    Jason Bobich

    @val Yeah, I would say something is up with the hosting account. Something seems off there, which is often a risk with these cheap shared hosting plans. You never know what all the hundreds of other customers you have to be sharing server resources with could be doing on their sites.


    I put the original setting file back where it belongs. Then I opened the wp-settings.php file and put in that line of code at the bottom of the other define code in the list. Then we reloaded Alyeska. It said it did it. But when we click Preview, we get a blank screen and if we go ahead and activate, we got this error message on the site page:

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 41 bytes) in /var/www/html/wp-content/themes/alyeska/framework/widgets/tb-widget-contact.php on line 19


    Host support said they’ve upped our memory to 128M and that’s the upper limit for them. What seems to be happening is some kind of loop that takes it to the max setting and then going beyond it.


    One more clue. I went to a different site on a different host (DreamHost). I made the change to the wp-config.php exactly as you say to and tried to do the upload through the WP admin Install Themes. It won’t let me get as far as the other hosting service would. I get a message that says: “Are you sure you want to do this? Please try again.” Perpetually. Can’t get past that.

    With the first site, the one where we intend to use Alyeska, we could get to the Preview/Activate portion of the install.

    I don’t know if this gives you any more clues as to the issue, but thought I’d let you know. DreamHost is the hosting company for the site I set up in June, which works perfectly.

    The one that works on DreamHost, installed June 2012:

    The one that doesn’t work on WestHost (it has a holding page up right now):

    Jason Bobich

    Yeah, there’s no way you need to have your memory limit jacked up any higher than 64MB. It really sounds like something is off with what you’re doing.

    Send me the following information and I will try and install the theme for you because I just can’t see this being possible if everything is setup correctly.

    – Your WordPress admin URL, username, and password.
    – Your FTP address, username, and password

    You can send this information to me privately by sending it through My Account > Submit private info here on the support website.

    Jason Bobich

    In the future, please post here when trying to communicate. I had honestly stopped checking for your information when I didn’t here anything here in our topic and no info was sent over a couple days after we spoke. I’ve got your info now, and I’m checking it out.

    Jason Bobich

    Wow, you’re using WordPres v3.1! That’s almost 2 years old. That’s the reason you’re having problems. Try updating to the latest version of WordPress, which is v3.5.1.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.