This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

YouTube url not embedding video

Viewing 15 replies - 1 through 15 (of 16 total)
  • Author
    Replies
  • #17113
    bartwindrum
    Participant

    btw, experimenting with
    https://www.youtube.com/watch?v=9TJlLzTEGRc&feature=youtu.be&t=44s
    the url that appears in a browser address bar when viewing the video (slightly adjusted timestamp), also fails to embed.

    #17114
    Jason Bobich
    Keymaster

    WordPress’s oembed (the functionality where WordPress transforms a URL into the embed) will only work in the content editor of a standard page or post. Are you trying to do it somewhere else? Like in the Builder interface? Or within the tabs?

    #17115
    bartwindrum
    Participant

    I’m working in the page editor. Tried both the visual and text view. I am using HTML Editor Syntax Highlighter plugin and Tiny MCE Advanced, which modify text and visual editors respectively (the former has always been installed as I built the site), and btw WP v3.9.1. Since we’re at this point in the thread I’ll wait to disable either/both before cutting and repasting the urls to see what you have to say next. Here are 2 screen grabs…

    http://s27.postimg.org/9ivqei99r/Screen_shot_2014_05_24_at_4_48_59_p.png

    http://s27.postimg.org/xb51q1ban/Screen_shot_2014_05_24_at_4_49_34_p.png

    #17116
    bartwindrum
    Participant

    Sorry for the 2nd input Jason but I forgot to mention that yes, I am using tabs on the page, as the pix will show or have shown you. I made the tabs after building the two pages they represent (and probably saved those pages after unpublishing them). I suppose, or hope, that there’s some workaround now that the Speaking page is built with tabs. I’m confused tho by your answer above in that the tabs exist within the standard page editing environment…

    #17117
    bartwindrum
    Participant

    Apparently I pasted the wrong image code above, so here’s the right codes to view the editing environment:

    http://postimg.org/image/fq3t5jgej/

    http://postimg.org/image/nubxaa2tn/

    Also, I deactivated the Tiny MCE Advanced and HTML Editor Syntax Highlighter and tried repasting both YouTube URLs. The problem persists so I guess it has something to do with tabs. I don’t recall if there’s a separate Tabs editing environment built into Akita or your reference to tabs refers to their existence on a page.

    #17118
    Jason Bobich
    Keymaster

    The video URL you should be using should be this:

    https://www.youtube.com/watch?v=9TJlLzTEGRc

    Have you tried inserting the video URL like this?

    It’s always formatted in the same way. You’ve got:

    1) Main YouTube URL watch page: https://youtube.com/watch
    2) Question mark, which is how you start passing $_GET variables through a URL: ?
    3) And then you just need the “v” ID parameter to equal the ID of the video: v=xxxxxx

    I know it’s confusing because they have different “share” URL’s but the URL you want to use is just the URL in your browser when you’re viewing the video. The stuff on the end of your URL &feature=youtu.be&t=44s is just extra parameters added on because of where you clicked from on youtube.com to get to the video page.

    So your original URL interprets as going to youtube.com/watch and then passing the following parameters to the page:

    v=9TJlLzTEGRc
    feature=youtu.be
    t=44s

    For our URL formatting, we only need the first “v” parameter. The other stuff isn’t relevant for us.

    These extra little variables are just so when you’re on YouTube.com, they know how you got to where you are. So, for our purposes, you can ditch that stuff on the end of the URL.

    #17120
    bartwindrum
    Participant

    Oh boy. Thank you; I’ll have to visit WordPress 3.9.1 video insertion documentation. For anyone else’s benefit, the game’s gotten (needlessly?) complex; you used to just paste the URL and what needed to happen to embed just happened. Now, I observe the following:

    • the t=44s parameter adjusts playback to begin 44 seconds in. Including this by itself at the end of the URL seems to disable or break the insertion process no matter which of the following two methods I used

    • method 1: direct paste in visual mode results in the url immediately turning blue (live) and being surrounded by a full-width 1 line tall bounding box with resize handles. Unlike pictures (at least under WP 3.8.x), double clicking brings up *no* control. In text view the result is something like:

    https://www.youtube.com/watch?v=9TJlLzTEGRc

    • method 2: using the new menu, choosing Insert>Video and pasting the url into the first field also requires one to spec a width (enter 638 in the first field; the 2nd field is height, which will auto-ajust if the constrain box is checked). What results is a gray box sized appropriately. Double clicking on it has no effect. The box chew up needless large vertical space in the editor. The new code in text view is wrapped in a new-to-me tag (which I can’t remember since I have saved the page only with a directly-pasted URL after learning that my colleague who posted the vid disabled embedding).

    Note too that any other vids previously inserted on the page appear in the visual editor merely as a text string, and in text view as they always did, text unadorned by additional code.

    #17121
    bartwindrum
    Participant

    The forum software stripped the tags from the text view past in my message above so I’ll try removing the symbols that designate tags in order to cause all what translates from inserting the url to appear here:

    td id=”tdWmMessage” align=”left”
    div id=”wmMessage” class=”wmMessage_user_text_special” a style=”color: #0000ff;” href=”https://www.youtube.com/watch?v=9TJlLzTEGRc” target=”_blank”>https://www.youtube.com/watch?v=9TJlLzTEGRc [then closing a, td, div tags]

    #17122
    bartwindrum
    Participant

    Maybe some of that extra YouTube encoding had to do with my colleague disabling the ability to embed ??

    #17127
    Jason Bobich
    Keymaster

    method 2: using the new menu, choosing Insert>Video and pasting the url into the first field also requires one to spec a width (enter 638 in the first field; the 2nd field is height, which will auto-ajust if the constrain box is checked).

    What is this that you’re referring to? I’m not familiar with this feature in WordPress? Are you sure this isn’t functionality from a plugin?

    #17128
    Jason Bobich
    Keymaster

    Maybe some of that extra YouTube encoding had to do with my colleague disabling the ability to embed

    The feature=youtu.be is just referring to how the user arrived at the YouTube page. It’s irrelvant for any sharing. I think it just means that whoever copied the link went to the YouTube page through a http://youtu.be/xxxx link, and then copied the URL from the top address bar of the browser, not fully knowing what all they’re copying.

    #17139
    bartwindrum
    Participant

    Ah: method 2 menu is from the plugin Tiny MCE Advanced. Which makes WP’s own new method all the more opaque. WTF happened to the uber simple previous method: paste in the URL, the embed happens and the video is sized to the full width of whatever container we’d built via Akita?

    #17142
    Jason Bobich
    Keymaster

    … Which makes WP’s own new method all the more opaque.

    In all honesty, I’m not sure what you’re referring to. I’m not sure if I missed something about 3.9 you’re pointing out, or if you’re mixing up plugin functionality with WordPress core. But as far as I know, nothing has changed about how you insert videos, other than now WordPress gives you a way to insert a “Video Playlist” — which isn’t what you’re talking about, I assume.

    WTF happened to the uber simple previous method: paste in the URL, the embed happens and the video is sized to the full width of whatever container we’d built via Akita?

    I’m still just not sure what you’re referring to. Maybe we’re just not on the same page. To my knowledge nothing has changed.

    Here’s a basic example page I just did to make sure I’m not totally missing the boat on something here.

    http://demoblvd.com/themes/akita/video-test/

    And here’s all I put in this example page’s content:

    Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam.
    
    http://www.youtube.com/watch?v=ginTCwWfGNY
    
    Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam.
    #17143
    Jason Bobich
    Keymaster

    If you’ve got some kind of other plugin taking control of videos, and on the frontend of your site, they’re filtering the same WordPress oembed output filters that Akita is, it would make sense that you’re not getting the right, responsive display Akita provides.

    #17144
    bartwindrum
    Participant

    Apparently so and I apologize, if need be, for the confusing length this thread has gone. I did test without the plugin (Tiny MCE Advanced — recently “upgraded”) but at that time was using share urls containing “youtu.be” so never had basic success including Akita’s full-width sizing. And thanks for pointing out that, in fact, the vid I put it and specced a width for is non responsive. I like to think I would have been smart enough to ponder and disable Tiny MCE but the whole otherwise simple process got waylayed by the funky share url YouTube gave me.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.