This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Widget Logic not working

  • Creator
    Topic
  • #6226
    bahlakesh
    Member

    Using the builder, my home page has a blog roll on it. I am forced to use default right sidebar, as opposed to a custom widget area. I have a signup box at the top of right sidebar default.

    I do not want to display the signup form on front page, or on the “Thank you for subscribing” and others…

    When I use Widget logic, it works to hide the sign up on the home page with

    ! is_front_page()

    and I can hide it on the signup page with

    ! is_page( 1151 )

    but it breaks both pages when i try the traditional

    ! is_front_page() || ! is_page( 1151 )

    and there are many other scenarios where I want to control the widgets without the headache of widget areas. Seems the logic of widget areas is redundant to me. I would rather hard code for as much effort as the widget areas cause to customize.

    Thoughts?

Viewing 1 replies (of 1 total)
  • Author
    Replies
  • #6249
    Jason Bobich
    Keymaster

    Hello,

    This has something to do with the paginated post list/grid element not getting the query restored properly after. This is something we’ve addressed in the next update, but still occasionally run into some weird issues on some server setups since WP 3.5.

    Are you using a Child theme? If so, try simply putting this anywhere in your Child theme’s functions.php. —

    add_action( 'themeblvd_post_list_paginated', 'wp_reset_query' );
    add_action( 'themeblvd_post_grid_paginated', 'wp_reset_query' );

    This could go in functions.php of the parent theme, as well, I suppose. Anyway, does this solve the issue and force your page to work as expected with your conditional? I’ve been testing setting up exactly what you’re describing on the live demo and I’m able to replicate the issue; this does solve the issue on my end.

    If this does not solve your issue, can I please see a live link to your site so I can see exactly what you’ve setup?

Viewing 1 replies (of 1 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.