This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

We're sent off to a feed

  • Creator
    Topic
  • #6600
    Kjetil
    Participant

    Hi
    We have a problem that has puzzled us for months – and that is driving people off our site – dolcevita.no:
    When somebody clicks any link (except the home link in the header logo), they are sent off to a feed. That is, even if the link looks right in the browser line, when clicked, they’re sent to feed://dolcevita.etc… instead of the supposed http://dolcevita.etc… Or they’re sent to a list with feed posts. At least that is how it looks. (Or – on my Mac, where I don’t have any feed reader – I’m sent over to Mail which gives me this “Error: No associated application could be found”.)
    This makes the site practically impossible to enter.

    The really funny part, though, is that the problem is unstable. It comes and goes. The only indication I’ve found here is if I change some files on the site. Then the problem almost consequently comes back.
    This makes testing hard and imprecise.

    Now, I’ve tried to isolate the cause of this problem.
    First: I use quite some plugins, and also a child theme of Alyeska. On an other site (dolcevita.no/blogg) I use the same child theme and many of the same plugins plus some others. I use WP 3.5.1, alyeska 2.5.1, framework 2.1.0 and the latest of all plugins.
    On dolcevita.no:
    – I’ve deactivated all plugins: Problem persists.
    – Switched to a default theme (twenty twelve): Problem gone (or at least for some minutes then)
    – Switched to my Alyeska child theme: Problem’s back
    – Switched to Alyeska motheer theme: Problem is first there, but then gone. I’ve left it for quite a while without more problems.
    This indicates that there’s a problem with the child theme I’ve made.

    In the child theme, there are two possible sources for an error:
    – Either the functions.php file
    I’ve just left in the html for the to meny line – today I have removed the code at the bottom here (only change made)
    – or in the cumstom.css file
    I’ve made may adjustments here, but nothing new.

    Now…
    – have you heard of anything similar before?
    – Any hint on what I should look for
    – If I can’t find the error this way, do you take paid support?

    Thanks,
    Kjetil

    PS Dolcevita.no is built with three wp installations. To stay inside the main part, avoid /blogg and /cucina

    ————–The code removed from the child theme’s functions.php——————–
    /*———————————————————————————–*/
    /* To remove the wp version
    /*———————————————————————————–*/

    function no_generator() { return ”; }
    add_filter( ‘the_generator’, ‘no_generator’ );

    /*———————————————————————————–*/
    /* Suuposed to give hackers less info when trying to log in */
    /*———————————————————————————–*/

    function explain_less_login_issues(){ return ‘ERROR: Entered credentials are incorrect.’;}
    add_filter( ‘login_errors’, ‘explain_less_login_issues’ );

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #6609
    Jason Bobich
    Keymaster

    Hello,

    I’ve looked at your site now a few different times in the last few hours, and I have not seen the issue you’re describing. I’m able to navigate around on your site as normal.

    This theme doesn’t (and no other theme should) have anything to do with how permalinks are generated on your site.

    The really funny part, though, is that the problem is unstable. It comes and goes.

    This suggests it’s not some sort of theme/plugin conflict with your site, but realistically that some kind of issues lies with your server. If the problem were due to some kind of conflict with a plugin/theme, that specific combination would most likely trigger the issue and it would persist. However, for the problem to be sporadic suggests that the issue lies somewhere else.

    PS Dolcevita.no is built with three wp installations. To stay inside the main part, avoid /blogg and /cucina

    This also suggests that something is probably off with your setup, as well. There’s no reason why you’d need to setup your site with three separate installations of WordPress.

    Realistically, it might be time to look into where you’re hosting your site, what kind of server setup you’re using, and what you’re doing with your WP installation.

    I wish I had a better answer for you, but I’ve honestly never heard of such an issue. This is all I could find on this:

    http://wordpress.org/support/topic/all-link-in-my-blog-always-go-to-my-feed

    #6615
    Kjetil
    Participant

    Thanks a lot for your thorough reply – just from your answer I learn a lot about how things work.
    Actually the problem SEEMS to be gone. I don’t really dare to believe it yet, but, yes, it seems so.
    If so, the code pieces at the bottom of my description was to blame. It is very well possible that I had misplaced it – and taht it triggered the malfunction. As I said, that was the only change I had made after – without luck – to deactivate all plugins.

    Realistically, it might be time to look into where you’re hosting your site,

    I have spoken to our web host about the problem some time ago. They know WordPress well and are considered to be very professional. Anyway I’ll keep your advice in mind. The link you included was also useful in that respect.

    PS Dolcevita.no is built with three wp installations.

    I just mentioned this to keep you on the right installation. The reason the site is set up that way has historical reasons. It started with just the blog (/blogg), then we extended the site with a new “main” part – and finally took online the recipe part (/cucina). Of course I could move everything into one installation, but it also has some practical advantages – like being able to shut down one part of the site while keeping the rest online. And now, to compare 2-3 quite similar setups in search for the source of our problems.

    Just so I know: Do you offer paid support?
    Thanks again,
    Kjetil

    #6616
    Kjetil
    Participant

    Sorry, I was too quick. The problem persists.
    The only thing I’ve done was to activate the plugins I had removed – and deactivated them again. Again, the problem comes back when I do some change on the server.

    There was one point I mentioned, that I had

    – Switched to a default theme (twenty twelve): Problem gone (or at least for some minutes then

    If I understand you correctly, you believe this is a coincidence, explained by the instability in the problem, right?
    Kj

    #6617
    Jason Bobich
    Keymaster

    If I understand you correctly, you believe this is a coincidence, explained by the instability in the problem, right?

    It’s just that, assuming a theme isn’t doing something it shouldn’t, no theme in general is going to have anything to do with WordPress generating links in various places is all I’m getting at.

    But I still am not seeing the issue. You’re sure it’s just not something on your computer or your area? Or maybe something with your system’s caching, or even something cached on your ISP (meaning your internet connection in your area)?

    Next time you see the issue, try first clearing your browser cache, and then visiting your site through a proxy server like this. This will tell you if others outside of your situation are experiencing this issue or not, as this will simulate essentially visiting your website from somewhere else in the world.

    Also, try turning off permalinks by going to Settings > Permalinks and setting them to “default”. Maybe there is something odd with how permalinks are being handled are your server. Knowing that could at least put you in the right direction with your host, as well.

    Just so I know: Do you offer paid support?

    Nope, just the free complimentary support outlined here:

    http://support.themeblvd.com/help/#terms

    #6665
    Kjetil
    Participant

    Thanks, Jason, for taking your time to share some thoughts.
    The problem definitely is still there, even just now. And I’ve tried it from work, asked several friends and also our Facebook users, and many people report the same issue.
    Also, I have tried all the time clearing caches to refresh viewing of the site, but not via a proxy server. I tried now – same problem. Tanks for your tip, though.
    Regarding permalinks, I’ve used one of the standard setups, “http://www.dolcevita.no/postname/” (I think is “post name” – I’m running a Norwegian setup…) By “default” I guess you mean “http://www.dolcevita.no/?p=123” That works(!) – for now – so we’ll see :o)
    (It kills many of the links in my menu, but they’re set up manually. For instance the category links there work. For now.)
    I don’t understand why this should make any difference, but don’t waste time on this :o)

    I’ll definitely discuss all these things you mention with our web host – I should have time to reach them tomorrow. Especially, caching on the web is interesting. This could make a problem persist even after the cause is removed.
    (But, if that is the case, I understand that is to be discussed with the internet provider locally? There are a few very big ones (in Norwegian scale), so in theory one provider could be part of the problem even in different areas.)

    Support? I’m truly grateful for you bothering – I believe I’m already pushing it. So thanks.
    Actually this problem showed up first time in July last year, it has just become more frequent. Also something to discuss with our web host, I guess.

    Thanks,
    Kj

    #6675
    Jason Bobich
    Keymaster

    In WordPress, there is a certain process that takes place in generating permalinks. When you change your permalink settings to “default” you’re effectively turning this process off

    The inner working of how permalinks are generated with WordPress, your server, and your .htaccess file can end up being complicated thing if everything doesn’t “just work” on your server.

    http://codex.wordpress.org/Using_Permalinks

    So, if turning permalinks off fixes the issue, it means now you have a better understanding of where the problem lies with your host. This could help them to help you with your issue.

    #6695
    Kjetil
    Participant

    Hello again
    This is just to tell you that THINGS ARE STILL WORKING!
    A big thanks – we have twisted our minds for months trying to figure out this, so – great!
    I’ve just had to repair several manual set links (from the old times) – and now Dolcevita.no is once again stable and enjoyable 🙂
    Thanks again for all your effort on this one – truly appreciated
    Kjetil

    #9397
    Kjetil
    Participant

    Just like to add in the final solution on this one:
    Switch to a new web host – that is, a new web hotel provider.
    The problem came and went even after my final post above. So, with only one suggested solution left – found it in a thread on wordpress.org – we switched to a new provider. So – all of this trouble turns out to be “something server-related” – though we still don´t know what.
    Since the switch, the problem is gone. Truly.
    Cheers,
    Kj

Viewing 8 replies - 1 through 8 (of 8 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.