This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Unable to Edit Menu

  • Creator
    Topic
  • #21784
    gsot
    Participant

    We updated to the new theme, but now we are unable to edit menus without unfortunate consequences. When I try to add any pages to the site, it adds every page in the site to the nav. To solve that, I have to go into customize and it shows that no navigation is selected as the primary (it keeps showing that I don’t have any menu selected even though I have selected the right menu multiple times). When I select the right menu, it then reverts to a menu that only has the first three dropdown navigations that it should.

    You can see what is showing now on the staging site: http://www.edu2015.gsot.edu
    It should look like: gsot.edu

    We have been trying to solve this for over a week and are completely at a loss.

Viewing 1 replies (of 1 total)
  • Author
    Replies
  • #21785
    Jason Bobich
    Keymaster

    Hello,

    In looking at the live site I can see your menu is rather large. This is a bit of a guess, but I don’t think your issue has anything to do with the theme, but the max_input_vars value on your server’s PHP configuration.

    Are you aware if PHP was recently updated on your server? Starting in PHP 5.3.9, there is a setting max_input_vars, which by default limits form submissions to 1,000 input fields. In other words, if you have a super large form you’re submitting, the data gets cut off after that 1,000th input. Specifically with a WordPress menu, the assignment of the menu is toward the bottom of the form. — So you can see logically how what you’re describing might happen.

    You can verify this is the issue temporarily by installing the following plugin. When activated, it will tell you when you save any form in your WP admin, how many inputs are being submitted and what your server allows.

    http://wordpress.org/plugins/wp-max-submit-protect/

    The solution is pretty simple; just increase the value on your server’s PHP configuration. It’s a very common issue if you want to Google more info about it. And I’m sure you can shoot a quick message to your web hosting support, and they will increase the value for you, no problem.

    Also helpful: http://docs.woothemes.com/document/problems-with-large-amounts-of-data-not-saving-variations-rates-etc/

Viewing 1 replies (of 1 total)

The forum ‘Swagger Responsive WordPress Theme’ is closed to new topics and replies.