Single posts crashing in iOS7 mobile browsers – from Jetpack comments

  • Creator
    Topic
  • #15265
    David Ould
    Participant

    hi Jason,

    Since upgrading the site to the latest version I’m seeing one small problem. On individual post pages (but not the homepage) the site is crashing every browser I use in iOS7. Other people are replicating this problem.

    Only started happening since I did the upgrade.

    http://davidould.net

    any thoughts?

    d

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #15266
    David Ould
    Participant

    sorry, should have made it clear – getting this issue on an iphone but not on ipad

    #15270
    David Ould
    Participant

    Jason, have switched over to non-mobile for mobile browsers just to stop the crash. Let me know if you want me to switch back to try and replicate the crash.

    #15271
    Jason Bobich
    Keymaster

    Hi,

    Does the issue happen all over your site or just single posts where you have the Jetpack comment form?

    #15294
    David Ould
    Participant

    hi Jason. Just single posts with the Jetpack comment form.

    #15309
    Jason Bobich
    Keymaster

    If you’d like to continue using the Jetpack comments feature, here is a CSS fix that will correct the conflict in Swagger 2.1+

    #sidebar_layout .sidebar_layout-inner > .row {
    	display: block;
    }

    Since, you’re not using a child theme, you could add this to Appearance > Theme Options > Styles > Custom CSS. If you were using a child theme, this would go in your child theme’s style.css.

    Note: For anyone using Swagger 2.0, this would be the fix:

    #sidebar_layout .sidebar_layout-inner > .row-fluid {
    	display: block;
    }
    #15311
    David Ould
    Participant

    thanks Jason. Put that in but still getting the crash. Have left it on mobile theme for you to see.

    #15313
    Jason Bobich
    Keymaster

    Dang, unfortunately this is a side effect of putting in the Custom CSS option and not an actual CSS file.

    Try putting it in like this instead:

    #sidebar_layout .sidebar_layout-inner .row {
    	display: block !important;
    }
    #15315
    David Ould
    Participant

    success! Thanks for the diligence, Jason.

Viewing 8 replies - 1 through 8 (of 8 total)

The forum ‘Swagger Responsive WordPress Theme’ is closed to new topics and replies.