This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Superfish settings for nav not sticking

  • Creator
    Topic
  • #2299
    sdaris
    Participant

    I want to get rid of all animated dropshadows across the board so I changed the following values in superfish.js to:

    dropShadows: false,

    It works for about 10 seconds then reverts back to the old settings. Is there a cache file somewhere that’s being read? I looked in my cPanel but could find no trace of one.

    I also tried to override this effect by including the following CSS:

    #access li a, #access li a:hover {text-shadow: 0px 0px 0px #000000 !important;}

    However, this also has no effect. Can you tell me the best way to change the sf menu settings and have them stick permanently? thx

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #2300
    Jason Bobich
    Keymaster

    Hello,

    I’m not totally sure I’m following what you’re trying to do. In this theme there is no shadow that Superfish is putting on the drop down menus that I’m aware of? That dropShadows parameter you’re fiddling with shouldn’t do anything because I don’t include the CSS needed for it to work; I never have in any of my themes.

    In this theme, all superfish’s javascript is doing is the following:

    1. Animating the dropdown menus in on hover.
    2. Outputting the arrows next to top-level menu items with dropdown menus.
    3. Delaying the dropdown menu before it fades out when the user hovers off.

    But anyway, there’s no cache or anything on the javsacript files unless you have some sort of caching plugin on your WordPress site. If you’re trying to change a parameter of superfish, you wouldn’t want to actually edit the superfish plugin file itself. You’d edit the themeblvd.js file from your Child theme where the superfish function is called, and pass different parameters to the function.

    http://dev.themeblvd.com/tutorial/overriding-a-framework-javascript-file/#example-2

    $("ul.sf-menu").superfish({ 
         foo: 'bar',
         foo2: 'bar2'
    });

    Now, from your CSS snippet you’re putting in here, it would suggest you’re talking about just the text shadow on the menu items in dropdowns? If so, this wouldn’t have anything to do with superfish. But your CSS snippet should work. I just tried it on my end and it did remove the CSS text shadow effect from the menu items.

    Maybe I could better help if you showed me a screenshot fo what you’re referring to and maybe a live link to your site?

    #2302
    sdaris
    Participant

    Thanks for your quick and detailed response. This did the trick. I was confused about the “text-shadow” showing up because I mistook it for what was actually the Superfish “animation: opacity” property. The way the menu items were animating into view made it look like they had a thicker “text-shadow” background so I just changed the parameter to animation: {opacity:’none’, height:’show’} and it’s good now. Here’s the result so far if you should feel so inclined to see it:
    pandaperio.com/pp2/

Viewing 2 replies - 1 through 2 (of 2 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.