This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

slider image uploader pop up is whacked out

  • Creator
    Topic
  • #7131
    jrevillini
    Participant

    WP 3.5.1
    I go to Sliders > Edit “Home Slider” > open the first slide > click “Get Image”

    Instead of the uploader popping up front and center, it loads below everything else with the left 50% of the uploader box off the screen to the left.

    http://i48.tinypic.com/2np0yo.png

    I’ve disabled all plugins and it still does this, but I feel it’s got to be my setup or everyone would be going nuts.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Author
    Replies
  • #7136
    Jason Bobich
    Keymaster

    Hello,

    Yeah, it’s sort of a strange issue because the actual functionality of bringing up the media uploader is something done by WordPress, and the theme’s admin page is just sort of hooking into that.

    What version of WordPress are you using? And what web browser and version are you using? — I’ll try to reproduce and if I can’t we can move forward from there for maybe some more specific to your setup.

    #7137
    jrevillini
    Participant

    WP 3.5.1, Chrome 26.0.1410.43 m, Windows 7.

    #7139
    Jason Bobich
    Keymaster

    Yeah, that doesn’t really add up. I’m not sure off the top of my head. Do you want to send over a login to your WP Admin, and I can check it out?

    If so, you can send the info through My Account > Submit private info here on the support site.

    #7140
    jrevillini
    Participant

    I figured it out. It doesn’t work if your admin area is available via SSL only, i.e. in wp-config.php you have
    define('FORCE_SSL_ADMIN', true);

    #7141
    jrevillini
    Participant

    you must have hardcoded some calls to stuff with the protocol as http. Newer browser security considers calls to grab content from http insecure when on https, so it blocks scripts and css and stuff.

    #7142
    Jason Bobich
    Keymaster

    No assets should be hard-coded with http. Everything uses WordPress functions to include assets.

    All URL’s to assets in the the Slider manager use the constants setup at the top of /framework/themeblvd.php.

    #7143
    jrevillini
    Participant

    Dunno what to tell ya. If you go to add a new post while in the admin area under SSL, you get no warnings in the console. If you go to your slider manager under SSL in wp-admin, you get stuff like
    [blocked] The page at https://xxxx.edu/staging/wp-admin/admin.php?page=slider_blvd ran insecure content from http://xxxx.edu/staging/wp-includes/js/thickbox/thickbox.css.
    And it just doesn’t work while in SSL mode.

    #7145
    Jason Bobich
    Keymaster

    When you have FORCE_SSL_ADMIN set to true, what do you have set for your site URL setting under Settings > General? I think the issue lies with that in the theme.

    #7147
    jrevillini
    Participant

    I have it set to the URL the public would use for the site (but I am staging changes hence the subdir): http://xxxx.edu/staging

    #7148
    Jason Bobich
    Keymaster

    As a test, try setting it to https://xxxx.edu/staging when you’ve got the FORCE_SSL_ADMIN enabled. Does that solve the original issue? — I know that’s not a realistic solution, but just trying to confirm if I have the issue solved on my end.

    #7150
    jrevillini
    Participant

    Works. Sheeit. You know more about wordpress than I do. Sheeit.

    #7155
    Jason Bobich
    Keymaster

    Yeah, in the media uploader addon (that originally came from WooThemes framework) for our options framework, incorporate some assets by doing get_option('site_url') instead of using get_site_url. — That should solve this issue moving forward.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.