This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Tagged: , ,

Redefining blog.. fine but..

  • Creator
    Topic
  • #6360
    shadoe
    Participant

    I’ve set up my site with a static frontpage and now want to link it to my “blog”-page.
    http://i47.tinypic.com/315li10.png
    I then proceeded to make a “blog”-page with the following setting
    http://i48.tinypic.com/jgnksx.png

    When I go to “home” it works fine and shows the build I’ve chosen and fixed.
    When In the menu I go to the “news”-page.. I get the frontpage all over again..

    And I can’t figure out why.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #6363
    shadoe
    Participant

    Adding that I’ve tried disabling permalinks, that is setting them to default and it shows different pages but for some reason it’s the same content on both.

    #6374
    Jason Bobich
    Keymaster

    Hello,

    I have a feeling that even though you set a static frontpage, you still selected a homepage layout from your Theme Options. If so, simply go to Appearance > Theme Options > Homepage > Homepage Content and select “posts”. Now your posts page will show posts.

    Why? — When you select a “posts page”, WordPress replaces that page with your theme’s homepage file. Remember that WordPress is traditionally blog homepage type of setup. The basic WordPress concept is that when you set a static frontpage, you want to move your “Blog” (or WP homepage) to some other page, right?

    So, when you set a “posts page” that page is no longer a traditional page. It no longer uses the standard page template of your theme, and thus whatever content, settings, page template, etc, you set over on that page becomes irrelevant. WordPress just uses that page as a placeholder to swap in the theme’s homepage file. And in this theme, that happens to be either posts by default or the homepage layout you selected from your Theme Options. —

    That’s why the two screenshot you’re showing sort of contradict each other. Also, it’s why in the video series, you seem to be mocking in the title of your topic here, nowhere does it say to select a posts page as you’re doing. It shows to just setup a static page, apply the Post List page template, and link to it — which is an alternate way to setup all of this. You have many options, is all.

    #6410
    shadoe
    Participant

    Hey Jason. I’m going to try your solution, I don’t doubt it works.
    A followup query though..

    Why give us the option of making the wrong decision? I’m sure there’s a reasonable explanation but for some reason I believe it should be possible for you (the theme) to detect if I’ve made some erroneous selection in either the theme-settings or the general settings of wordpress?

    Nevertheless, hopping over to the devsite to see it this works now 🙂

    And, of course, it did…

    #6421
    Jason Bobich
    Keymaster

    Why give us the option of making the wrong decision?

    Yeah, definitely a valid point. There could probably easily be some sort of check for if it is a “posts page” or not before taking on the homepage layout setting (which should just become irrelevant).

Viewing 4 replies - 1 through 4 (of 4 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.