This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Post List doesn't display posts

  • Creator
    Topic
  • #7199
    agima
    Member

    When I create a page and set it to use the post list template it only shows an empty post and not the real posts. I change it to a post grid and it works as expected.

    However if I set the front page displays to use “your latest posts” and have the page as a grid list everything thing seems to work.

    However I want a normal page to be my home page but when I change this I have to change my blog page so that it is a blog grid for it to work.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #7204
    Jason Bobich
    Keymaster

    Hello,

    I’m sure there’s just a simple misunderstanding in the theme’s settings.

    When I create a page and set it to use the post list template it only shows an empty post and not the real posts.

    It would be really helpful to see a link so I can understand what you mean by this. Can you please setup your website the way you’d like and provide a link? If I could see what you’re setting up, I can probably give you a more straight-forward answer, opposed to guessing, and possibly confusing the situation further.

    #7255
    agima
    Member

    Cool.

    Here is a page that is setup to use grid list:

    http://www.bsimplistic.com.au/blog-list/

    Here is the page with blog-grid

    http://www.bsimplistic.com.au/blog/

    You can see on the blog grid page you have one test blog, but the blog list doesn’t show any posts.

    #7256
    Jason Bobich
    Keymaster

    Do you have any custom fields on the page where you have the Post List page template assigned? Note sure? Try creating a brand new page, applying the Post List page template, and then viewing that page. Same problem?

    What do you have selected for included categories on your Theme Options at Appearance > Theme Options > Content > Primary Posts Display?

    #7270
    agima
    Member

    The grid list in the example above I created from scratch to show you. So yes it is the same problem.

    Have a look at the PDF of the them page.

    http://www.bsimplistic.com.au/wp-content/uploads/2013/04/ContentPage.pdf

    #7277
    Jason Bobich
    Keymaster

    It doesn’t sounds like you understand quite what I’m getting at. That’s all right, though. Shoot me a login to your WP admin and I’d be glad to check it out. I’m sure there’s a simple explanation.

    You can send the info through My Account > Submit private info here on the support website. Post here once you’ve done this.

    #7320
    agima
    Member

    Thanks for getting back to me..

    I have now created you an admin account and submitted the details through the “submit private info”

    #7325
    Jason Bobich
    Keymaster

    I have to be honest; this one is still a bit of a mystery to me. I had tried disabling your plugins and switching around some of the Primary Post Display settings on your theme options page, but couldn’t pinpoint where the query was getting screwed up on that page. I then put everything back the way I found it and from then on, your post list page, and other ones I created with the template all started working correctly.

    http://www.bsimplistic.com.au/blog-list/

    #7367
    agima
    Member

    Computers hey! 😉

    Thanks for taking a look and yes I can also confirm that it seems to be working as expected. I even created a new page and it works on that page also.

    Once again thanks as it was sending me a bit batty.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.