This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Post Grid template in Alyeska child theme

  • Creator
    Topic
  • #7568
    iohannis
    Participant

    Hi,

    I have set up a child theme for Alyeska, and everything is working great, so far. The only issue I have, is that when I change the blog page (Settings > Reading) to a static page, and change the template for that page to Post Grid, the change does not take effect. Regardless of the changes I make (and specifically emptying caches in WP), I cannot get the Post Grid to show up on the blog page. I have watched your viedo instructions, and have attempted to solve it by adding meta values like a specific category, limiting rows or columns, but nothing helps. I also copied the content-grid.php from the alyeska parent to the child theme, but it makes no difference.

    Please help me troubleshoot this issue.

    Thanks,
    Calle

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #7574
    Jason Bobich
    Keymaster

    Hello Calle,

    It sounds like there’s some confusion in what is happening in WordPress when you select a “posts page” — When you do this, WordPress sees this now as your “homepage”, while what you perceive as your homepage is now your “static frontpage”. So, WordPress does a bit of a swap. The static front page will use that static page, while the posts page/homepage will use the theme’s homepage file (i.e. index.php).

    In other words, setting a “posts page” means that anything you do on that page — content, settings, page templates — becomes irrelevant because WordPress is not actually using the “page”.

    The short answer to your question is to go back to your Settings > Reading and simply select nothing for a “posts page” — Since the theme comes with page templates you can use, there’s no reason to even set a posts page.

    #7586
    iohannis
    Participant

    Thanks Jason, that was it – it wasn’t clear to me from the documentation/tutorials that the settings should be empty, and not the other way around.

Viewing 2 replies - 1 through 2 (of 2 total)

The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.