This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Portfolio pagination

  • Creator
    Topic
  • #1708
    alecss
    Member

    Hi, sorry for my frequent questions.

    I have a problem with portfolio pagination. When my porfolio items fill the page, doesn’t appear the pagination link to older portfolio items.

    How can I fix this problem?

    Thanks

Viewing 9 replies - 1 through 9 (of 9 total)
  • Author
    Replies
  • #1712
    Jason Bobich
    Keymaster

    I’ve heard of the next page of a portfolio items not coming up when the user click to go to it, but I’ve honestly never heard of any issue from anyone where the “Older Entries” link or pagination buttons (if you have WP-PageNavi installed) does not show up at all.

    Are you sure you have more than the amount of portfolio items on a single page then you specified for setting on how many portfolio items to show for each page? Have you edited any theme files like taxonomy.php? Or anything related to the themeblvd_pagination function?

    #1774
    alecss
    Member

    Hi, there was a problem that I have fixed, now “Older entries” is shown correctly.

    But, as you have already written, the Older entries link doesn’t not works. If you click on it, you’ll go in a non existing page.

    Here you can see the problem http://messaggeridelmare.alecss.it/portfolio/dicono-di-noi/

    How can I fix this?

    Thanks

    #1782
    Jason Bobich
    Keymaster

    Go to Settings > Reading > Blog posts to show at most and change the number to 9, so it matches what you have set for your portfolio pages.

    #1809
    alecss
    Member

    I have already set to 9 the blog posts to show most, but ai have put in the portfolio more than 9 items and they will increase in the near future.

    The problem is the older posts link take to a non existing page. You can see to yourself by following the above link.

    #1838
    Jason Bobich
    Keymaster

    Yes, I understand. Your “Older Entries” link goes to a 404 page. But I don’t think you’re quite understanding what I’m explaining to you.

    I’ll try to explain a little more descriptively. — In most cases, when this happens, it is because the “posts per page” option of the portfolio pages is conflicting with the global “posts per page” option of WordPress located at Settings > Reading on your server. This happens to some people and can be resolved by ensuring that global posts per page setting to matches the setting you’ve setup on your portfolio.

    So, in your site, make sure the two following settings match:

    1) Settings > Reading > blog posts to show at most
    2) Complexity > Theme Options > Portfolios > How many items per page?

    So, make sure both of these options have the same number. This should solve your issue. If it does not, let me know.

    #1851
    alecss
    Member

    Sorry, effectivly I didn’t understand. Now all is clear, many thanks. Tomorrow I’ll try and If something goes wrong, I’ll let you know.

    #1971
    alecss
    Member

    Ok for this aspect , now the pagination works properly.

    I have another need for the portfolio section: the 3 element that I have set to display in home, must be shown by date. Now they appear randomly and it’s not good for my purpose.

    Thanks

    #1972
    Jason Bobich
    Keymaster

    To make chronological, this is how you’d do it. Open this file of the theme.

    /includes/theme_functions/complexity_portfolio.php

    Towards the top, find this:

    $query_string = "post_type=portfolio-item&order=ASC&orderby=menu_order&posts_per_page=$num";

    And change to this:

    $query_string = "post_type=portfolio-item&posts_per_page=$num";
    #2002
    alecss
    Member

    Many thanks, now all works well.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The forum ‘Commodore WordPress Theme (formerly Complexity)’ is closed to new topics and replies.