This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Plugin install notice

  • Creator
    Topic
  • #7583
    askwpgirl
    Participant

    Hi Jason,

    I have site with latest Jump Start that is showing the plugin install notice and no option to dismiss. Is there anyway I can force this notice to go away? It also is showing the plugins all listed twice in the notice area. Weird.

    Thanks,

    Angela

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #7599
    Jason Bobich
    Keymaster

    Hello Angela,

    There should be a link to dismiss; there always has been. Can I see a screenshot?

    #7703
    askwpgirl
    Participant

    I dropped the database tables and reinstalled. That fixed it. I think something got messed up in the database. It was showing the plugins in the notice twice with no dismiss. Other issues made me think that there was something really weird going on. Thanks.

    #7706
    askwpgirl
    Participant

    Spoke too soon. So, it seems to be a weird conflict with the SmartyPants document manager plugin. When I activate that plugin, the duplicate plugin message displays and the dismiss link is gone. I had dismissed it when I first activated my JS theme, but then when I activated the SmartyPants plugin, the JS plugin message with duplicate listings of the plugins re-appeared. See screenshot:

    http://tinypic.com/r/1613f6/4

    #7916
    askwpgirl
    Participant

    Hi Jason,

    Each time I activated the Smarty Pants plugin (http://smartypantsplugins.com/) I would get the JS plugin notice listing the plugins 2x in the notice and/or two notices. It was so crazy. The client was eager to “resolve” the issue. There were no other errors except some database errors that I sent to their developer which he said were “soft errors” and would not cause problems. So, to “fix” the problem, I edited the JS themeblvd.php file to remove the calls to the plugins.

    I did a clean install on MAMP with latest JS parent and child to test, and I get same results.

    The message from JS looks like the old plugin message – the one without the dismiss link — and it displays the plugins twice exactly as in the tinypic above.

    So strange. Any ideas? Here are the errors that the plugin is generating:

    [28-Apr-2013 04:46:38] WordPress database error Table 'wp_sp_cu_forms' already exists for query 
    CREATE TABLE  `wp_sp_cu_forms` (
      `id` int(11) NOT NULL AUTO_INCREMENT,
      `name` varchar(255) NOT NULL,
      `template` text NOT NULL,
      `type` varchar(255) NOT NULL,
      `defaults` text NOT NULL,  
      `sort` int(11) NOT NULL DEFAULT "0",
      `required` varchar(11) NOT NULL DEFAULT "No",
      PRIMARY KEY (`id`)
    )  made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), include_once('/plugins/sp-client-document-manager-premium/index.php'), sp_client_upload_install_premium, dbDelta
    [28-Apr-2013 04:46:38] WordPress database error Duplicate column name 'cid' for query ALTER TABLE `wp_sp_cu` ADD `cid` INT( 11 ) NOT NULL; made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), include_once('/plugins/sp-client-document-manager-premium/index.php'), sp_client_upload_install_premium
    [28-Apr-2013 04:46:38] WordPress database error Duplicate column name 'tags' for query ALTER TABLE `wp_sp_cu` ADD `tags` text NOT NULL; made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), include_once('/plugins/sp-client-document-manager-premium/index.php'), sp_client_upload_install_premium
    [28-Apr-2013 04:46:38] WordPress database error Duplicate column name 'parent' for query ALTER TABLE `wp_sp_cu_project` ADD `parent` INT( 11 ) NOT NULL DEFAULT '0' made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), include_once('/plugins/sp-client-document-manager-premium/index.php'), sp_client_upload_install_premium
    [28-Apr-2013 04:46:38] WordPress database error Duplicate column name 'locked' for query ALTER TABLE `wp_sp_cu_groups` ADD `locked` INT( 1 ) NOT NULL DEFAULT '0' made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), include_once('/plugins/sp-client-document-manager-premium/index.php'), sp_client_upload_install_premium
    #7920
    Jason Bobich
    Keymaster

    I would say the plugin you’re using is doing some very custom, “non-WordPress-y” stuff. If that conflicts somehow with the theme’s little Plugin installer, I’d say that’s not a real big deal. I’d just disable it. But I’d keep your eyes open for other odd issues and conflicts this plugin may have with other things, moving forward.

    Anyway, you can completely get rid of the theme’s plugin installer by unhooking the “themeblvd_plugins” function from your Child theme’s functions.php:

    remove_action( 'after_setup_theme', 'themeblvd_plugins' );
    #7939
    askwpgirl
    Participant

    Thanks! They are working to resolve errors on the plugin. It’s actually a very cool plugin for which they are doing a lot of development work on now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.