This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Pagination not working – Post Grid (paginated)

  • Creator
    Topic
  • #1967
    Oberon
    Participant

    I’m not sure what I’m doing wrong. I have a Theme Builder custom layout with a “Post Grid (paginated)” item in the “Primary Area”. I’m setting “Rows Per Page” to 2 and there are 11 posts (Columns is set to 3). This means I should have 2 pages. The pagination controls show up correctly at the bottom of the page, but when I click on the “2” for page 2, it just redirects back to my root home page url. When I hover over the “2” link, I see that it’s pointing at /page/2/ which looks reasonable. But when I click on that it just reverts back to the root url.

    The site is currently here: http://sugarloafphoto.com/blog
    (I will leave the pagination set to 2 rows per page for now even though it’s blocking some posts)

    It’s kinda rough still as I’ve only spent a couple hours getting it up and running.
    But I have to say, what I’m seeing so far looks pretty cool with this framework.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #1982
    Jason Bobich
    Keymaster

    Hello,

    How did you setup your homepage? Is it a custom layout assigned to a static page that’s then assigned to as a “static frontpage” from Settings > Reading > Frontpage displays?

    If so, that’s the problem. Weird things happen with pagination in WordPress when you try to do it from a static page as your frontpage.

    1. Go to Settings > Reading > Frontpage displays and select “your latest posts”.
    2. Then, go to Appearance > Theme Options > Content > Homepage and select your custom layout there.
    #1991
    Oberon
    Participant

    You’re right, I did have Settings > Reading > Frontpage set to a static page, so I changed that.
    I already had the Theme Options Homepage set to my custom layout

    I’ve saved that change, reloaded and still see the same problem. Do I need to clear cache.

    Ah! Ok, it’s working now. I had to clear the browser cache. I also tried a different browser and it’s working there as well.

    Thanks!!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.