This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Tagged: 

Paginated post list show Error 404

  • Creator
    Topic
  • #22109
    mirecek5
    Participant

    Hello!

    I have made a custom template with Post list (paginated). The post list uses a custom query with the special post type “reference”. The first page is ok, but if you click to page 2, it returns HTTP 404. Here is the link: http://www.cevelova.cz/reference/

    Please, do you have any idea what is wrong and how to fix it? Thank you very much.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Author
    Replies
  • #22112
    Jason Bobich
    Keymaster

    Hello,

    First, let’s see if it’s an issue with your site’s permalink structure. — What do you currently have set for your permalinks under Settings > Permalinks of your WP admin?

    If you temporarily turn permalinks off (i.e. set to “Default”), and try the page again on your site, does it work? If it does, then we know it’s most likely an issue with how your permalinks were previously set.

    #22117
    mirecek5
    Participant

    Hello! Thank you very much for your reply.

    I have set /post-name/. I have tried setting to Default, but it did not work either. 🙁

    #22135
    Jason Bobich
    Keymaster

    Honestly, I haven’t run into this issue with anyone else. So I can’t really think of any other reason this could be happening off the top of my head.

    If you like, I can take a closer look in your admin, and see if anything else comes to mind? If you’d like that you can send me a login to your WordPress admin so I can check it out.

    You can send the info here: http://support.themeblvd.com/forums/users/mirecek5/edit/#private

    #22160
    mirecek5
    Participant

    Thank you very much. I just would need your IP address. My hosting company has the wordpress administration restricted to certain IP addressses. Sorry for inconvenience.

    #22169
    Jason Bobich
    Keymaster

    That might be kind of tough because I’m currently traveling around. But you can give it a try with my current IP if you can get back to me in time.

    [removed]

    #22197
    mirecek5
    Participant

    I have just send the information and set up the IP address. Thank you very much for your help!

    #22207
    Jason Bobich
    Keymaster

    I’ve headed back to the state I live and my IP has thus changed. The next time I’m at the Internet connection in my home, I’ll guess I’ll post my IP again to you. I don’t know what that is off the top of my head.

    #22210
    Jason Bobich
    Keymaster

    IP is now: [removed]

    #22214
    mirecek5
    Participant

    IP set up, you can try it.

    #22233
    Jason Bobich
    Keymaster

    I still can’t access. Remembering back to your issue, I was still a bit of a loss. Here’s what I was going to try in troubleshooting:

    1) a: Turn permalinks to “Default” and test. b: Turn permalinks to “Day and name” and test. — I know you said you did this, but I was going to test for myself.

    My gut still tells me it’s something with permalink settings. I find that when people use any other permalink settings than “Day and name” (aside from turning off/default, which noone would want to do), weird things happen as your site becomes more complex.

    So, I’m saying in my experience it’s best to always use “Day and name” — In reality, this only effects blog posts. Your pages will still display as yoursite.com/foo

    2) Could it be something weird about the specific page? I would create a completely new page, with new name, and assign the page template, and see if the issue exists on the new page.

    3) Is it the page template itself? Or pagination on a static page, in general? I was going to apply a “Custom Layout” using layout builder, and insert a paginated post list element. This would give you the exact same result as using the page template, but just another route of getting there.

    4) Is there any kind of caching going on? I was going to check if you were running in WordPress caching plugin, and disable it to see if its having an effect. What about the webhost? Are they caching URLs or pages on your site? Some sort of built-in caching for WordPress that is outside of your hands?

    #22416
    mirecek5
    Participant

    I am sorry, I was also out for some time, with very limited access to the internet.

    But finally, I tried the steps you propose and it worked!

    It seems something was wrong with the page name “reference”. So I have created a completely new page with the different name (Ohlasy) and it shows following pages normally.

    Thank you very much for your help!

Viewing 11 replies - 1 through 11 (of 11 total)

The forum ‘Barely Corporate Responsive WordPress Theme’ is closed to new topics and replies.