This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Omitting Categories from Home page and blog page

  • Creator
    Topic
  • #3485
    annenelson
    Participant

    Hi, I realise there is a reply to this, but even now I am registered and logged in, I cannot see the solution as it is locked.
    I am trying to omit specific categories and ONLY show my ‘News’ & ‘Offers and Competitions’ categories (ID’s 3 & 4) on the home page and main blog page – however, ALL posts from ALL categories are showing on both pages, no matter what I do!

    I have implemented this as follows:
    1. On the Main blog page ‘News & Events’ – I have entered the following shortcode [post_list categories=”category-3,category-4″ thumbs=”small” post_content=”content” numberposts=”10″ orderby=”post_date” order=”DESC” offset=”0″ link=”true” link_text=”Read More” link_target=”_self”] – however, ALL my categories are still appearing on this page.
    2. I have set up the home page with a custom layout – and set the lower section as ‘From an external page’ then set this page to ‘News & Events’ – again ALL posts from ALL categories are appearing.
    3. I have checked my settings in both Theme settings and global settings to ensure that the Home page is set to display ‘Custom Layout from Home Page, and Excluded the categories I wish to omit from the Theme Options Content section.
    Can you tell if I am missing something or is there a fault within the system?
    I would appreciate your quick response on this as I am implementing this as an upgrade from an earlier version of Alyeska (which worked perfectly) for my client and their site is currently down for maintenance until we can resolve this issue.
    Thank you,
    Anne Nelson

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #3523
    Jason Bobich
    Keymaster

    Hello,

    Have you checked out the “Redefining the blog” video series in your documentation? I think you’ll find the first two videos helpful.

    Video #1: https://vimeo.com/32754914
    Video #2: https://vimeo.com/32754998

    1. On the Main blog page ‘News & Events’ – I have entered the following shortcode [post_list categories=”category-3,category-4″ thumbs=”small” post_content=”content” numberposts=”10″ orderby=”post_date” order=”DESC” offset=”0″ link=”true” link_text=”Read More” link_target=”_self”] – however, ALL my categories are still appearing on this page.

    First off, to create your blog page, you don’t really want to use a shortcode.

    1) Create a page.
    2) Apply the “Post List” page template.
    3) And now what you excluded from Appearance > Theme Options > Content > Primary Posts Display will take effect on this page.

    2. I have set up the home page with a custom layout – and set the lower section as ‘From an external page’ then set this page to ‘News & Events’ – again ALL posts from ALL categories are appearing.

    This isn’t how you want to include your posts into your custom layout and now won’t work because you’re not using a shortcode in that page.

    Within your custom layout you want to add either the element called “Post List” or the element called “Post List (paginated)” — Then in the settings for that element simply check the categories you want to include there.

    =====

    Also, on a separate note just for future reference, I noticed that above when you were trying to use the [post_list] shortcode (which you were implementing on both your blog page and homepage), you were using “category-3” and “category-4” as your category slugs. Unless you’ve specifically made these the slugs of your categories, this is most likely not correct. They are most likely something like “news” and “offers-and-competitions” — WordPress shows you what these slugs are from the Posts > Categories page.

    #6117
    annenelson
    Participant

    Hi There,

    Thank you for your prompt response on my last query. I have managed to implement all of the above and it now works as it should.
    However, my client has just pointed out that the links to the rest of the posts don’t work at the bottom of the Post List on the home page.
    I have the Home page ‘Post List’ set up within the Page Builder, and have my chosen Categories set to display, with the ‘Posts per Page’ set to ‘5’ – it DOES display the first 5 posts, but when you then click on the 1,2,3 pages numbers below to display the rest of the post page lists, they don’t do anything.
    The Home page and post list can be viewed here: http://www.lochlomondshores.com/
    Can you advise what may be going wrong?
    Best Regards,
    Anne Nelson

    #6118
    Jason Bobich
    Keymaster

    You can’t have a static frontpage with pagination. Under Settings > Reading > Frontpage Displays, select “your latest posts.” Then, go to Appearance > Theme Options > Content > Homepage, and select your new custom layout as the content for the homepage.

    http://themeforest.net/item/alyeska-responsive-wordpress-theme/164366/faqs

    #13981
    mpam
    Participant

    I discovered that for a page-grid it’s working in a likewise manner:
    go to your page-editingscreen of the desired page. Open the “page-Grid (Paginated)’ tab en check the desired categoryboxes

Viewing 4 replies - 1 through 4 (of 4 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.