This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

New Posts link to 404 page

  • Creator
    Topic
  • #6187
    beno
    Participant

    Hi,

    I’m building a site and about a month ago I created some test posts. Each with a gallery and some copy. All good.

    Now I’m creating real posts with the same settings as before but now the read more button takes me to a 404 error page. I’ve check all the post settings over and over. I restored some of the tests post that I knew worked before but now they too give me the dreaded 404.

    Its probably simple but i can’t figure out whats going on. I’ve created many new posts, deleted them and tried again with the same results. There nothing in the Permalink or URL that raises any eyebrows. But then I’m not much of a coder and have limited hmtl experience.

    Here’s a link http://blissoncrown.net.au/dev/masseuses/
    – The first post “Arielle” is a new post.
    – The second “test_Candy” is an old one that works
    – The third “test_Rose” is an old post that worked fine, but then I deleted. I then restored it and now its not working.

    Please help,
    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #6200
    Jason Bobich
    Keymaster

    Hello,

    Just in general with WordPress, the first step is to determine if the issue is a permalinks issue or not (usually it is). Go to Settings > Permalinks, turn your permalinks off (i.e. set them to “default”) and save the settings.

    Now check your website. Do all of your posts come up properly with permalinks turned off? If they do, it means your issue is something to do with how you’re configuring your permalink settings.

    #6207
    beno
    Participant

    I set the permalinks back to default and it works! But when I set it back to Post Name its back to 404 pages.

    Not sure what to do now. I would like to have Post Name as the setting.

    #6216
    beno
    Participant

    I think I’ve found a solution.

    I’ve created a custom permalinks structure. I added /%category%/

    So now its /%category%/%postname%/

    Seems this has been a very common problem

Viewing 3 replies - 1 through 3 (of 3 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.