This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Multiple complication with theme

  • Creator
    Topic
  • #10025
    shake2450
    Participant

    Hi again

    Not sure where to start. I bought the Alyeska theme because it looks great and have all the features I want. So far so good. But when I try to make Business Homepage #4 to be my welcome page, I get different complications. If the’re connected with each other or I’m just doing something wrong, I don’t know.

    Here’s the thing: In Builder/Add new layout I choose the Business Homepage #4, give it my own name and click Add new layout. But then I get this: http://mindcology.dk/. And when I click Blog in the menu, I get this: Warning: Invalid argument supplied for foreach() in /var/www/mindcology.dk/public_html/wp-content/themes/alyeska/framework/frontend/functions/general.php on line 801.

    I must admin that I am no professional at this, but I do try to figure things out on my own. However, after a week with running in circles, I really need some help now. As it seem to me there no “mother panel” that overwrites everything else. Correct me if I’m wrong, but it looks like some setting in the WordPress panel overwrites everything and some other settings in the theme panel that overwrites everything else. So I am very confused.

    I even tried to install the theme again, but came up with the same problems.

    Any help/good advise is highly appreciated.

    Kind regards, Johnny

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #10038
    Jason Bobich
    Keymaster

    Hello Johnny,

    I’ve gone into your site, and the good news is that there is nothing weird about your server, and the theme should work just fine. It looks like there’s just some misunderstandings in how the theme works. I’ve got your site going the way I think you were trying to do. So, let me cover a few points.

    There are two ways to a set a custom layout to a homepage. You were sort of mixing the two methods. Here’s the sort of step by step for what you have setup now, and what I’ve done for you, so you can go back and make adjustments.

    1) I went to to the Layout Builder. You already had layouts setup and ready to go. I picked the “MIT Design” as the one you wanted to use for your homepage.

    2) I went to Settings > Reading > Frontpage displays, and could see you have a static page set as your frontpage called “Velkommen” and the page “Blog” as your posts page. — This means you are using Homepage Method #1 from the Layout Builder section of your documentation that came in your download package, and so the the setting at Appearance > Theme Options > Content > Homepage is not how you should be assigning your custom layout. I fixed this on your Theme Options page, as well.

    3) Then I went to edit the “Velkommen” page and you had the “Custom Layout” page template attached, but you had no layout saved to it. I’m assuming at some point you created a layout, assigned it, then deleted it from the Builder, maybe when you were experimenting around. This is why you were getting “Invalid Layout ID” on your homepage.

    So, I selected the “MIT Design” under “Custom Layout” and updated the page. This brought your homepage back.

    4) The next issue is the errors on your blog page. This was a similar issue to the homepage. You had a custom layout assigned to the page you were telling WordPress you wanted to use as your “posts page”. I just changed this back to the default page template so WordPress can do it’s thing and replace it with the standard blogroll.

    Note: It looks like most of the big errors you were getting that you were referencing were because I think you were creating layouts, assigning them, and then deleting them. Your homepage and blog pages had non-existing layouts assigned to them, which should only be possible if they existed at some point for you to select them.

    ========

    So, now you can go back to the Builder, and continue editing the “MIT Design” layout if you want to get going on that homepage.

    =========

    Also, for reference, here are the two ways of setting up a homepage with a custom layout from your documentation. Remember that these are two separate methods. So, you would pick one or the other.

    Method 1: Create your custom layout, apply it to a static page, and then assign that page as your static frontpage under Settings > Reading > Frontpage Displays.

    Method 2: Under Settings > Reading > Frontpage Displays, select “your latest posts.” Create your custom layout. Then, go to Appearance > Theme Options > Content > Homepage, and select your new custom layout as the content for the homepage. — If you’re using an element in your custom layout that uses post pagination, make sure you use this method.

    #10043
    shake2450
    Participant

    Absolutely brilliant. Thank you, Jason. I´m not sure I understand everything, but you´ve given me alot to work with…:-)

Viewing 2 replies - 1 through 2 (of 2 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.