This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Tagged: ,

Most recent posts not showing up on blog page

  • Creator
    Topic
  • #7869
    marc.natale
    Member

    My company has a site with a page for blog articles (http://www.balestrierefariello.com/blog/), but when I access the blog through my iPhone, I cannot see the most recent article. Any suggestions on how to fix this? Thanks.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Author
    Replies
  • #7880
    Jason Bobich
    Keymaster

    Hello Marc,

    I’m not quite sure I understand the issue. When I view your site on my iPhone or on my computer I see the “Looking To the Future” post at the start. What are you seeing on your iPhone? Can you try to describe the problem in a little more detail?

    #7883
    marc.natale
    Member

    The Looking To the Future article is not the most recent article. That article was posted on April 11th. There’s a more recent article, “The Public Safety Exception” (http://www.balestrierefariello.com/the-public-safety-exception/) which was posted yesterday, April 25th. When I click on Blog on the menu bar, it takes me to the Blog page and the first article is The Public Safety Exception, followed by Looking To the Future. But, when I click on Blog in the menu on my iPhone, Looking To the Future is the first article. I am unable to locate The Public Safety Exception on my iPhone when clicking on the Blog menu item. I can see the article when I click on a direct link to the article. Hope this clarifies things a little. Thanks.

    #7887
    Jason Bobich
    Keymaster

    For me, “The Public Safety Exception” is no where to be found on your blog page, no matter where you’re viewing it from. Are you sure you don’t have the “Civil Rights” category excluded from your blog page? Have you setup any custom fields on this blog page? What do you have set under Appearance > Theme Options > Content > Primary Posts Display > Categories?

    #7889
    marc.natale
    Member

    No excluded categories under Appearance > Theme Options > Content > Primary Posts Display > Categories.

    Weird. Guess I should have used a browser where I wasn’t signed into WP. I confirmed that it does not show up in the main Blog page on another browser, but I can see it when I click on the archive articles section for April (http://www.balestrierefariello.com/2013/04/), even though it lists one (1) article, when I click on April, I see both the The Public Safety Exception and the Looking To the Future articles. I have not made any changes to the Public Safety Exception article that would prevent it from appearing in the main Blog page. I’ll keep looking, and maybe I inadvertently clicked on something, but all the settings appear the same for the two articles that we’re referencing.

    #7891
    Jason Bobich
    Keymaster

    Yeah that is strange. I was thinking maybe the post was set to private or something, but then it wouldn’t show in the category archive. But there’s got to be something weird about how that post is setup. Checkout it’s publish settings. Checkout any plugins you might be using that schedule or control post publishing in any way, maybe? Try playing around with creating some new test posts and putting them in that category, and see if you can narrow down a pattern.

    #7937
    marc.natale
    Member

    I deleted the The Public Safety Exception and reposted but no luck. I also created a test post, but it behaves in the same way as the The Public Safety Exception post. I’ll keep looking for issues, but let me know if anything else comes to mind.

    #7948
    Jason Bobich
    Keymaster

    If you want to send me a login to your WP site, I can take a look when I get chance. I have to think there’s some simple explanation we’re just not thinking of.

    If you want me to do take a look, go to My Account > Submit private info here on the support website, and you can send me your login details. Please post here after you do this.

    #7952
    marc.natale
    Member

    Ok – thanks. Just submitted the requested user info.

    #7953
    Jason Bobich
    Keymaster

    All right, so the reason is because of the W3 Total Cache plugin. I just went to Performance > Dashboard, and clicked the “empty all caches” buttons, and then your posts appeared on the next refresh over on the non-logged in window I had open.

    Here’s the support forum for Total Cache if you want some more advice on possibly alternate ways you can setup the Total Cache settings to avoid this kind of behavior. I’m not too savvy with the plugin, but I imagine there’s a lot of different ways you can setup the caching.

    http://wordpress.org/support/plugin/w3-total-cache

    #7960
    marc.natale
    Member

    Nice. Looks great. Thanks for looking into this! I’ll look further into the Total Cache re: alternative settings.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The forum ‘Akita Responsive WordPress Theme’ is closed to new topics and replies.