This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Tagged: 

Miscellaneous Lightbox Issues (Hover Icon Missing, Plugin Conflict)

  • Creator
    Topic
  • #22092
    ross
    Participant

    Having some difficulties with the lightbox;

    a) the auto lightbox shortcodes don’t get inserted when using the Raw HTML plugin (kind of need this plugin)

    b) the docs say that you’re using Magnific Popup but the instructional video says PrettyPhoto, can you confirm which one please?

    c) if I disable Raw HTML and enable Settings > Writing > Raw Shortcode along with Auto Lightbox, then the shortcodes get inserted, but on the frontend, the + signs do not appear when hovering over thumbnails

    Beautiful theme, thanks!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #22093
    Jason Bobich
    Keymaster

    Hello,

    a) the auto lightbox shortcodes don’t get inserted when using the Raw HTML plugin (kind of need this plugin)

    If you have it enabled and the reason it doesn’t work is because of a conflict with a third-party plugin you’re using in conjunction — Unfortunately there’s not really anything we can do about that.

    Would the [raw] shorcode that’s already built-in to our shortcodes plugin work for you as an alternative? As long as you disable the Visual editor (or make sure you never switch over to the Visual Editor when editing posts with complex HTML), then our [raw] shortcode should allow you to do pretty much anything, I would think?

    [raw]
    <div class="foo">
        <div class="bar">
            <p>Whatever ...</p>
        </div>
    </div>
    [/raw]

    b) the docs say that you’re using Magnific Popup but the instructional video says PrettyPhoto, can you confirm which one please?

    The video is a little older. The current lightbox in the theme is Magnific Popup, but this doesn’t change the functionality of how the [lightbox] shortcode is inserted into your post or how it’s configured.

    c) if I disable Raw HTML and enable Settings > Writing > Raw Shortcode along with Auto Lightbox, then the shortcodes get inserted, but on the frontend, the + signs do not appear when hovering over thumbnails

    Can you link me to a live example?

    • This reply was modified 5 years, 1 month ago by Jason Bobich.
    #22095
    ross
    Participant

    Hello,

    a) will the native [raw] shortcode preserve javascript as well?
    b) ok
    c) still running on localhost, but I’ll contact you again when it’s viewable (if it doesn’t sort itself out)… any thoughts off the top of your head?

    #22099
    Jason Bobich
    Keymaster

    a) So the thing to understand is that our [raw] shortcode isn’t doing anything in the in actually saving your post content. It terms of what is actually saving, you’re at the mercy of what allows to be saved through (which I believe should include most javascript).

    But what our [raw] shortcode is doing, is eliminating any frontend WordPress automatic formatting that happens on the outputted markup and scripts you’ve saved.

    Using the example I provided before, if you didn’t have the raw shortcode, you may end up with something like this being outputted on the frontend of your site:

    <p><div class="foo"><br>
        <div class="bar"><br>
            <p>Whatever ...</p>
        </div><br>
    </div></p>

    c) Do you have the frame turned on? If I remember right, I believe the icon only shows if you set frame=true.

    #22104
    ross
    Participant

    Yes, the shortcode seems do it automatically, but I doubled checked regardless, and they are all frame=”true”

    Here is the entire code:

    [lightbox link="http://localhost/clients/sbr/wp-content/uploads/2015/06/lodge.jpg" thumb="http://localhost/clients/sbr/wp-content/uploads/2015/06/lodge-300x195.jpg" width="300" align="left" title="" frame="true" icon="image" caption=""]
    • This reply was modified 5 years, 1 month ago by ross. Reason: code sample
    #22110
    Jason Bobich
    Keymaster

    c) I think this is an issue with the plugin. I’m currently on my honey moon, actually! But I will put this on my to-do list and when I can, I’ll see if I can update the plugin so the little icon shows in Framework 2.4 themes. As time goes on, these little Theme Blvd plugins can get difficult to manage, because they need to work with so many different versions of themes.

    #22114
    ross
    Participant

    Ok, sounds good

    Honeymoon? Congratulations!

    I had another question, but certainly don’t want to interrupt… when are you expected back?

    #22125
    Jason Bobich
    Keymaster

    I’ll be back on Monday, but no worries, I just wanted to let you know the timing of my answers may be a little more inconsistent than normal this week.

Viewing 7 replies - 1 through 7 (of 7 total)

The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.