This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

mini post widgets displaying all posts despite setting it at 3

  • Creator
    Topic
  • #1737
    lasry02
    Member

    The mini post widgets are displaying all posts in the sidebar despite being limited to 3 in the widget settings. This is only happening on Chrome and IE. Firefox is working fine. I am running wordpress 3.5 with swagger theme v1.1.5.

    Is there a solution? Am I missing something?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Author
    Replies
  • #1738
    lasry02
    Member
    #1740
    Jason Bobich
    Keymaster

    What else is on the page you’re displaying the widget on? Can I see a specific link to the issue? It doesn’t really make sense that an issue like this would be different in one web browser than another, unless I’m misunderstanding the issue.

    #1741
    lasry02
    Member

    everythinglakewood.com you’re right, it is now not working on any browser. It shows 6 recent posts and its set to 3 in the widget settings.

    #1746
    Jason Bobich
    Keymaster

    It’s something to do with the actual paginated post list on that page. (Notice how it doesn’t happen when you click through to your single posts and the number of posts in the widget matches the number in the post list.)

    I have a feeling this has something to do with a issue that’s been addressed already for the next update. Try adding this to your Child theme’s functions.php —

    function my_reset_query(){
    	wp_reset_query();
    }
    add_action( 'themeblvd_element_post_list_paginated_after', 'my_reset_query' );
    add_action( 'themeblvd_element_post_grid_paginated_after', 'my_reset_query' );

    Does that solve the issue?

    #1747
    lasry02
    Member

    Nope, it did not solve the issue.

    #1748
    Jason Bobich
    Keymaster

    If you want to provide a login to your WordPress site, I can check it out.

    You can submit the info to me through your “My Account” page here in the forums.

    #1750
    lasry02
    Member

    I just submitted the info in my account page. Thanks in advance!

    #1751
    Jason Bobich
    Keymaster

    Within your widget’s options, I put showposts=3 for the custom query and that fixes the issue for you. I’ll look further into the issue for future updates to the theme.

    #1755
    lasry02
    Member

    Thanks! can you just tell me what my custom query for category is? I want only 3 post and only from one category? Thanks again for the quick responses!

    #1761
    Jason Bobich
    Keymaster

    If you want use the category’s numerical ID, you’d do it like this:

    cat=1&showposts=3

    And if you wanted to use the category’s slug, you’d do it like this:

    category_name=foo&showposts=3
Viewing 10 replies - 1 through 10 (of 10 total)
  • The forum ‘Swagger Responsive WordPress Theme’ is closed to new topics and replies.