This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Mini Post List & Grid Widgets

  • Creator
    Topic
  • #592
    mark m
    Member

    Finally upgraded to 2.1.5 from 2.1.1 and I wanted to change the number of posts to display using the mini post list widget from 5 to 4, but no matter what I put, it always stays at 5. Same when I tried to switch to the grid widget.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #593
    Jason Bobich
    Keymaster

    Hello,

    Can i see a link to the issue? I want to see what you have around the widget and how it’s setup.

    Do you have a paginated post list incorporated where you have the widget? I’m wondering if this is similar to this: http://support.themeblvd.com/forums/topic/blotter-recents/

    #1857
    mike-se
    Participant

    I think I have might figured out this problem. If I have a custom builder page with say a paginated post list – and it is set to get “All Categories”, then the Mini Post List Widget will get all post in the category chosen by the widget, even if I set it to get only 1. If I uncheck the “All Categories” on the builder page, and instead check all categories separately the Mini Post List works fine and will retreive only the number of posts set in the widget.

    #1872
    Jason Bobich
    Keymaster

    Yeah, I haven’t quite figured out why this happens. I’ve had a couple of people report similar things, but haven’t been able to duplicate on my servers.

    One workaround you can use that I figured out for someone else is that you can use showposts in the custom query string option like this:

    showposts=3

    Or

    category_name=foo&showposts=3

    In WordPress showposts is deprecated and I’m honestly not sure why it overrides the number of posts in the widget but the way I have it (supposedly the correct way) does not. So, I’m looking more into this.

    #1898
    ejb5oh
    Participant

    Showpost=4 worked for me. Thanks Jason!! I am sure you will find the issue and fix it in your next release when you release the MAJOR AWESOME UPGRADE too!! Happy Holidays!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.