This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Lightbox for gallery

  • Creator
    Topic
  • #5710
    Lars
    Participant

    Is it not working in WP 3.5.1?

Viewing 12 replies - 1 through 12 (of 12 total)
  • Author
    Replies
  • #5727
    Jason Bobich
    Keymaster

    Hello,

    This is a bug currently with WordPress when inserting a gallery where it strips out the bit about linking to the file. It doesn’t have anything to do with the theme. They’ve got it in trac and marked for the next update, so I’m sure it’ll get worked out.

    http://core.trac.wordpress.org/ticket/23298

    … but realistically, you can just type the link="file" manually within your gallery shortcode in the meantime.

    #7321
    daganray
    Participant

    After I updated JumpStart to 1.0.1 the
    link=”file”
    code in my gallery shortcode stopped working

    #7322
    daganray
    Participant


    After I updated JumpStart to 1.0.1 the
    link=”file”
    code in my gallery shortcode stopped working

    I meant JumpStart to 1.0.2

    #7327
    Jason Bobich
    Keymaster

    Hello,

    Are you sure that you have link=”file” manually places in the gallery shortcode when you’re saving the page?

    If so, can you please provide a link to the issue?

    As far as I can tell, galleries and the lightbox all work fine in the current version:

    http://www.themeblvd.com/demo/jumpstart/features/lightbox-integration/

    #7329
    daganray
    Participant

    <a title="" href="http://oceanadventure.com.ph/dev/wp-content/uploads/2013/03/sea-lion-show-1.jpg" rel="themeblvd_lightbox"><img class="aligncenter size-full wp-image-169" alt="sealion show" src="http://oceanadventure.com.ph/dev/assets/sealion-show.jpg" width="579" height="290" /></a>

    and

    [gallery ids="1662,1661,1660,1659,1668,1667,1831,1832,1833" link="file"]

    These both worked on the site perfect, ie, opened to a lightbox. Then after the update they just link to the image without a PrettyPhoto lightbox.

    http://oceanadventure.com.ph/dev/experience-the-adventure/feature-shows/sea-lion-marine-patrol/

    #7337
    Jason Bobich
    Keymaster

    Ok, so everything is setup properly on your site, however the new localized variables for the javascript that allow for this new feature are not present.

    I notice that you are running Super Cache. Assuming you haven’t edited any of the functions that control the framework’s javascript output, I would say it’s a caching issue. Did you clear your cache after updating the theme? — I don’t know the ins and outs of the Super Cache plugin, but I think that’s where the problem is. Are you able to confirm this? Or does this help you to get to your answer?

    #7364
    daganray
    Participant

    Ok, so everything is setup properly on your site, however the new localized variables for the javascript that allow for this new feature are not present

    Where should these variables be so I can check and get them in place?

    I notice that you are running Super Cache

    Super Cache is the first plugin I installed on the dev site and PrettyPhoto has been working well with it.

    Assuming you haven’t edited any of the functions that control the framework’s javascript output

    Nope

    #7365
    Jason Bobich
    Keymaster

    The point is not that Super Cache has some sort of conflict with prettyPhoto. It’s you have certain outputs of the theme cached by the plugin and now these have changed (I’m assuming, anyway). I’ve honestly never used the plugin so I can’t tell you how clearing its cache works, but I’d imagine there’s a simple way to do this. You could also just deactivate the plugin temporarily to verify, as well.

    These screenshot show you specifically where the issue is. Notice how you’re missing all of the javascript variables added in Jump Start v1.0.1.

    Jump Start live demo: http://www.uploadblvd.com/uploads/image_51663db283130.png

    Your site: http://www.uploadblvd.com/uploads/image_51663e3764105.png

    #7370
    daganray
    Participant

    Problem fixed, but still a bit of a mystery.

    Back in the previous version of Jump Start I had customized
    jumpstart/frontend/api/locals.php
    to change the wording of a string in the themeblvd_get_all_locals function

    After updating JumpStart, the locals.php file didn’t get overwritten with the new version, mine was still there and only had part of the themeblvd_get_js_locals function there, which it seems to me was all that was there in the original version 1.01 file.

    So anyway, all fixed now – thanks for your help and keep up the good work.

    #7374
    Jason Bobich
    Keymaster

    It’s best to avoid pluggable functions where ever you can, and only use as a last resort. Always use hooks and filters if you can. In this case, if you wanted to add/remove/change any of those text strings, you’d want to be doing it via the filter that’s there, opposed to actually editing the function.

    #7409
    daganray
    Participant

    OK – based on the Filter tutorial in you response above, I wrote this function in my child theme functions.php and restored the original locals.php in Jump Start

    function my_frontend_locals( $locals ) {
    		$locals['crumb_404'] = 'Page Does Not Exist';
        	return $locals;
    	}
    	add_filter( 'themeblvd_frontend_locals', 'my_frontend_locals' );

    Thanks for all your tutorials and support. I’m actually learning the advance stuff =)

    #7421
    Jason Bobich
    Keymaster

    Awesome, that is perfect. That’s exactly the idea here. And now in the future when we add strings there to pull from, your modifications will continue to work. When you’re looking to edit things that are returned or various variables that get used in different functions, you will see tons of filters throughout the framework, and hopefully now you’ll have a new level of options for your development and customizations. 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.