This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Jumpstart 2.0 beta2 auto-embed youtube is 1200px wide

  • Creator
    Topic
  • #20154
    Israel Curtis
    Participant

    when using the built-in link parsing for wordpress (no shortcode, just URL on a line), the resulting youtube videos are coming out 1200px wide (spilling out of the main column and across the right sidebar. When I switch to twentyfourteen or twentyfifteen theme, the videos are scaled properly to fit in the main post column (much smaller). I can’t find anything in my configuration to control the width such automatic embeds are displayed at…

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #20155
    Jason Bobich
    Keymaster

    Do you have a live link that demonstrates the issue?

    #20156
    Israel Curtis
    Participant

    I remembered that Jetpack also included some video shortcode functionality. Now I’m not using shortcodes, just raw URL. But when the “Shortcode Embeds” module in Jetpack 3.3 is enabled, it appears to conflict with your layout. I was able to recreate by disabling Jetpack altogether or just that module. Note that the module doesn’t cause such a problem with themes other than Jumpstart.

    #20157
    Israel Curtis
    Participant

    With Jetpack enabled, this is the code that gets output for youtube links:

    <p><span class='embed-youtube' style='text-align:center; display: block;'><iframe class='youtube-player' type='text/html' width='1200' height='705' src='http://www.youtube.com/embed/IwvHDcm49ZI?version=3&rel=1&fs=1&showsearch=0&showinfo=1&iv_load_policy=1&wmode=transparent' frameborder='0' allowfullscreen='true'></iframe></span></p>

    And here’s what shows with the module disabled:

    <div class="themeblvd-video-wrapper">
    <div class="video-inner"><iframe width="1200" height="900" src="http://www.youtube.com/embed/IwvHDcm49ZI?feature=oembed&wmode=transparent" frameborder="0" allowfullscreen></iframe></div>
    </div>
    #20158
    Israel Curtis
    Participant

    Also note that the “shortcode embeds” module is enabled by default on all Jetpack installations

    #20159
    Jason Bobich
    Keymaster

    Yes the issue would be jet pack. It’s something that’s come up here in the forums several times in the last couple years. You need to disable their video module if you want to use the theme’s responsiveness for videos.

    #20160
    Jason Bobich
    Keymaster

    From another topic, not sure if the solution still works or not:

    Ok so the reason this happens is because of JetPack’s Shortcode Embeds module. They basically abandon WordPress’s default oEmbed functionality for embedding YouTube videos. So, there’s no way for the theme’s responsive wrapper to get in there because JetPack is now embedding the YouTube video.

    A quick fix is just to disable the Shortcode Embeds module from your JetPack options page. When on your JetPack options page, click the “Learn More” button beneath Shortcode Embeds, and then click the “Deactivate” button.

    If this doesn’t work for you, and you need the other embed shortcodes JetPack provides, adding this to your child theme’s functions.php should also do the trick:

    remove_action( 'init', 'wpcom_youtube_embed_crazy_url_init' );
Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.