This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Jump Start vs. PHP 5.4.x?

  • Creator
    Topic
  • #8644
    karlo
    Participant

    Just wanted to ask if Jump Start is being tested in PHP 5.4.x?

    I did super fast test with wp debug and thought I noticed a few Jump Start specific warnings/notices. I stopped and went back to 5.3.x which I assume is also what is considered standard – even if deprecated by PHP gods.

    Considering plugins and WordPress in general loving old PHP versions it is probably stupid to go with 5.4.x, but if Jump Start is PHP hipster, idea might pop up again. Pointless if 5.3.x is max. Can get some weird output with that debug. Are correct but also kind of false positives or waste of time.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #8653
    Jason Bobich
    Keymaster

    I usually have my MAMP configured with 5.2 and always have WP_DEBUG on. I just switched to 5.4 and clicked through my current working version of the theme and couldn’t find any warnings or anything. So, if you find something specific, let me know.

    #8656
    karlo
    Participant

    Hmm, I will if I go all out on 5.4.x Have tried reporting “bugs” to devs. so know debug logs cant always to be trusted. One issue here trigger another there, and if you can only make sense of wrong one you end up talking rubbish. Will require Jump Start only test that is for sure. No plugins. If you were hot on 5.4 I might start to focus on plugins declaring that as compatible – if possible to find. Just because I could.

    Have not noticed any debug issues on 5.3.x. so considering that will not be part of WordPress until 2014 or something this is just a crazy idea. My big nose tell me many devs. check on and use, 5.3.x. – but with dead 5.2.x version in mind because of WordPress being backwards. Very few 5.4.x.

    I wish they would add a notice to installer. “Oh we see your server is using old PHP 5.2.x. 5.2.x does not even get security fixes any more, and we have been told it is known to hurt SEO as Google prefer fast and lean engines. Shall we proceed? Up to you…”. Few days later all lazy hosts are on min. 5.3x πŸ™‚

    #9259
    karlo
    Participant

    Now I have been on PHP 5.4.x (the very latest) for a while I see no issues with regards to JumpStart. Including most of its plugins.

    Lots of other nagging crap though, not just “notices” but “warnings” – like https://github.com/aprea/live-comment-preview/commit/91abfc44606ffc4fb11553de35a442d2f7cbe572 “Creating default object from empty value” is already old with PHP 5.4 πŸ™‚ I have seen many similar stories, devs. often sometimes suggest to turn “error” reporting off. As in “does the site work, yes? ok then fine”. I think why not declare PHP as your wife? It IS, heh. Deal with it. Underlying issue is then that most devs. only test with 5.2.x because WP is backwards because of marketing reasons. WP ignore PHP in a way.

    Well, almost strange to check memory usage 5.2.x vs. 5.4.x It simply drops like massively. From lets say 69.5mb to 48mb. Just like that. I guess deprecated since almost 3 years (including security update) vs. “fairly new” means something? New tech or something? Improvements? bug fixes? Possibly, would not be unheard of with web technologies πŸ™‚

    #9260
    karlo
    Participant
    if( is_object($post) ) 
            $post_format = get_post_format();

    from docs http://dev.themeblvd.com/tutorial/incorporating-post-formats/ must be new and I believe also take care of a notice or 2?

    Whatever, newer PHP is better πŸ™‚

    #9262
    Jason Bobich
    Keymaster

    Hey Karlo,

    So do you have any specific examples of things in the theme that you’re getting PHP notices or warnings from? In using PHP 5.4, I’m not able to find anything.

    #9272
    karlo
    Participant

    No not from Jumpstart. From other plugins yes. PHP 5.4 wont be a success for all WP devs. You can see the github link, is same for all. And there is most likey more. If you really do not test on anything newer than 5.2.x this is not a bad result πŸ™‚

    I noticed a big theme, ithemes Builder, yesterday put out a bug fix specifically for WP 3.6 and PHP 5.4, 5.5. Issues are to be expected. On plugin forums etc. I have seen them mentioned with PHP 5.4 many times. Fixes required. May be you know what to look out for?

    I still dont see much point in not testing and developing for current PHP, which is actually PHP 5.5 but that is a special WP story. From a logical stand point this is nuts. I have seen some complain about WP being locked in the past. Besides there being potential security issues! PHP 5.2.x is dead according to PHP, since years! They say you can do what you like, WP certainly does not stand in your way. Fact is of course that most devs. will follow what WP encourage. Officially or unofficially. And that is status quo πŸ™‚ Status quo is not cool with web tech but for some reason many WP kings and hosts dissagree. Have to mention big hosts of course, all one big family.

    I know HostGator now forces all new shared accounts on at least PHP 5.3.x so it is changing.

    Is actually worse, http://wordpress.org/about/stats/ What decide what is cool or not are in fact dead sites on outdated WP versions πŸ™‚ Notice WP verson stats. Hmm, may be start by updating WP would be an idea?

    #9273
    karlo
    Participant

    Fount itheme builder update http://ithemes.com/codex/page/Builder/Release_Notes/4.2.2

    In WordPress 3.6, many new notices and warnings will appear on sites that have WP_DEBUG enabled. This release makes a large number of changes to avoid the causes of those notices and warnings. In addition, sites running PHP 5.4 or the newly release PHP 5.5 will see even more notices and warnings. This release also addresses those issues.

    Not relevant for Jumpstart but might be typical anyway. We will see.

    Apparently also done because of WP 3.6. I have not tested Jumpstart on WP 3.6 a whole lot. Doing that with debug enabled might show something weird. Not sure if directly related to PHP 5.4+. I doubt it.

    #9274
    karlo
    Participant

    Check this http://yoast.com/mea-culpa-on-a-bad-update-lessons-learned/

    He goes

    I think it’s fair to say the majority of web hosts out there are lunatics. If it’s your job to make sure web servers run fast and secure, how on earth can you run software on it that hasn’t been supported for over 2.5 years?

    AND then he switch his dev. stuff back to PHP 5.2.x

    Yes that make sense πŸ˜‰

    Is WP which directs progress even if they wont admit it. Them and certain hosts. Almost seems like there is a hidden world with a shit load of outdated WP sites, on outdated hosts. Probably dead sites. And they influence what is considered good for majority. Weird.

    Anyway, the link to github issue which got fixed is one of the “bugs” from PHP 5.4 Use 5.3.x all is fine, also 5.2.x

    More interesting to know what WP 3.6 has to do with notices/warnings, per PHP version. Is that not what ithemes are hinting? 3.5.x will be irrelevant soon so issues will come out.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.