This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Conflicts with wp-types plugin: javascript used to hide .group

  • Creator
    Topic
  • #7383
    Darryl Schmidt
    Participant

    Hi, I’m having an issue with one of the plugins, WP-Views, that I need to run.

    The WP-Views support fellow said:

    I have tested in your test site, your theme is using a JS to hide all “.group” HTML element, all Views Shortcode in pop-up window are wraped in


    , please try contact your theme author for this problem

    /wp-content/themes/jumpstart/framework/admin/options/js/options.min.js?ver=2.2.1
    c(“.group”).hide();

Viewing 14 replies - 1 through 14 (of 14 total)
  • Author
    Replies
  • #7385
    Darryl Schmidt
    Participant

    Oh, if it helps, I only have an issue when Theme Blvd Layout Builder and/or Theme Blvd Widget Areas are acitve.

    #7386
    karlo
    Participant

    I have same problem but since I could fix it I did not bother posting. Also I did not expect Jason to have a clue on Types&Views, which you did not link to http://wp-types.com/ 🙂

    /* .editor_addon_dropdown .direct-links { display: block !important; } */
    .editor_addon_dropdown .group { display: block !important; }

    Should put it back on. First line or element I actually think is meant to be hidden.

    I load my own CSS in Admin, also for these kind of issues. You can do the same

    // load CSS file in Admin
    add_action( 'admin_enqueue_scripts', 'Admin_CSS_JS' );
    function Admin_CSS_JS() {
    	wp_enqueue_style( 'admin-css', get_stylesheet_directory_uri() .'/assets/css/admin.css', array(), '1.0', 'all' );
    }

    You can also just echo it out with and add_action on admin_head. There are also plugins that let you run own CSS, JS in admin, like Add Admin CSS http://wordpress.org/extend/plugins/add-admin-css/

    #7387
    karlo
    Participant
    #7388
    karlo
    Participant

    Damn cant edit, think too slow…

    I dont know if Views win this one and Jason have to fix but in general keep eye on Types&Views. They are not always following admin standards, for as much as there are any. Look up “Tabify Edit Screen” plugin for example http://wordpress.org/extend/plugins/tabify-edit-screen/ He made a fork of Types to make it behave, lol. Their metabox creations are “alternative”. And if you fire up Firebug/Inspector you can see more hints plugin is huge and may be not super polished. Used to be much worse though and they improve all the time. Just have to keep eyes open for weird stuff, not all is as obvious as this white screen you have now.

    #7398
    Jason Bobich
    Keymaster

    Hello,

    Yeah, I’ve definitely never used the plugin, but if the issue is simply that we’re hiding generic ‘.group’ class, this could probably be done better anyway. I’ll look into this and post back here on this topic a little later.

    #7400
    Jason Bobich
    Keymaster

    All right, here’s a fix for this.

    1) Create a file options.js in your Child theme with this content: https://gist.github.com/themeblvd/5374994

    2) In your Child theme’s functions.php, register this javascript file with id “themeblvd_options” —

    function my_scripts(){
    	wp_register_script( 'themeblvd_options', get_stylesheet_directory_uri().'/options.js' );
    }
    add_action( 'admin_enqueue_scripts', 'my_scripts', 9 );
    #7401
    Darryl Schmidt
    Participant

    That did it alright.

    Thanks for your help Jason and karlo.

    #7678
    Darryl Schmidt
    Participant

    I just noticed that with that code in my funtions.php it messes up a plethora of things associated with jumpstart, like the theme options menu, the builder plugin, etc.

    #7679
    Jason Bobich
    Keymaster

    You sure? Like what? Can you give some specific examples I can look for? I’ve got this JS file implemented and haven’t see anything strange.

    #7681
    karlo
    Participant

    I just tried JS fix with Views activated. Cant really see any negative changes, works.

    There is a battle going on in admin regarding CSS, JS so not possible to compare. You should test with only Jump Start and Types&Views activated.

    Is Types&Views not GPL? Types must be and they are in family. Well you could send monster package to Jason, for educational purposes and 100% true test. I dont think he has to do anything, issue will pop up after install.

    #7682
    Jason Bobich
    Keymaster

    Oh I didn’t realize he meant more conflicts with Jump Start and this types and views plugin. That’s really not the type if plugin I’d change things around specifically for. The .group was more of a general best practice kind of thing.

    #7733
    karlo
    Participant

    Ok, well it apparently fixed issue for me, I did disable CSS fix first!, and since I have same Types&Views I will guess a new conflict have been born at Darryl installation. I dont see any Jump Start GUI messed up.

    I actually did see an issue in Builder/Custom Layout when I first looked. An ugly square is attached to all “li” s. Except it comes from another plugin, loads on all admin pages and change core values for core elements, post-box something. I just had not noticed before. Anything is possible in back-end 🙂 Good that Firebug and other dev. tools works there too, or it would be a massive guessing/blame game.

    #7892
    twitchylegs
    Participant

    Wow – Very glad I found this post after discovering the same issue with the two plugins. Thanks for the fix!!

    Perhaps the title should be updated to better reflect the issue: wp-types issue with Views ‘add field’

    #8712
    Darryl Schmidt
    Participant

    Ok, I just had another look at this. Everything that looked messed up was because I didn’t create the options.js

    All is well.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.