This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Tagged: 

Logo Image Not HTTPS Aware?

  • Creator
    Topic
  • #13139
    kennethfeldman
    Participant

    Have Jump Start.

    Trying to set up site with some HTTPS pages (e-commerce).

    But the Jump Start theme logo image (set via theme options) does not seem to be HTTPS aware — that is to say that the image path is inserted to the HTML page as HTTP… and not HTTPS… when the page is loaded via HTTPS.

    THis causes a browser alert due to the non-secure connection that the logo image makes.

    All other JS, and CSS, and other assets seem to load with the HTTPS path. It’s just the LOGO image that doesn’t.

    Any fix or thoughts?

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #13140
    kennethfeldman
    Participant

    Hi Again,

    One more incidence to note….

    Though it’s not going to affect my project, I can see that slider images are also not getting the HTTPS in their path when connecting to the page via HTTPS.

    Thanks.

    #13145
    Jason Bobich
    Keymaster

    Hello,

    These two items, the logo image and the slider images, are both static URL’s that you’re saving our from your admin. These URL’s are not pulled dynamically when everything loads on the frontend. Especially with sliders, this allows us to get drastically improved performance on your site by pulling saved URL’s, opposed to dynamically trying to pull the URL for each image dynamically, hitting your MySQL database for each one.

    Anyway, the solution to your issue is just to re-save these items with “https” in the URL’s. The logo is the easiest. Just go to Appearance > Theme Options, and for your logo image, just change it and re-save it. For your sliders, this happens in the background when you save a slider. You need to turn on SSL in your WordPress admin, and then when you save the slider, all of the image URL’s will be saved with “https”.

    #13151
    kennethfeldman
    Participant

    Great! I have adjusted the logo URL, and will try the slider images next.

    Thanks again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.