This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

HTTP error on image upload

  • Creator
    Topic
  • #25659
    Mark Wiard
    Participant

    I have an issue on this site: http://globalhighperformance.com/

    It is a pretty straightforward Jumpstart site with child theme. A few weeks ago, we started to get an error every time we tried to upload an image, either in the media uploader or in a post.

    The upload proceeds to 100%, and stops here – no crunching happens, and after a few seconds, I get an HTTP error at the top of the uploader page.

    This is usually a permission error, or memory error, not the case here.

    I have turned off all plugins, and the error remains.

    If I change to 2016 theme, the upload works fine every time. If I go back to the Jumpstart parent theme, the error comes back, the same with the child theme. This is repeatable, and seems to indicate some issue with Jumpstart. I have version 2.04, and did a reinstall direct from a fresh download.

    Of course Jumpstart works fine for many installs, including several others of my own.

    I think the root issue, this is hosted on Godaddy managed WordPress. I suspect they are doing something in here to “help out”, that is disagreeing with Jumpstart. I know that if I call Godaddy, they will just blame the theme, and not provide any real help.

    I am thinking that the crunching step where Jumpstart makes some custom images sizes is failing.

    Any suggestions for me?

    mark

Viewing 3 replies - 1 through 3 (of 3 total)
  • Author
    Replies
  • #25660
    Jason Bobich
    Keymaster

    Hello Mark,

    I get where you’re coming from, but the only way it could be a theme issue is just that the theme is essentially doing too much, or adding too many crop sizes, I guess. The theme doesn’t actually do anything when this process is happenning. So, it’s possible that just with all the image sizes registered, this is causing too much work when an image is being uploaded that your hosting is setup to give up or timeout at a certain point.

    From a theme perspective, I’m not sure what to tell you other than you could pretty easily just filter the theme’s registered crop sizes and remove ones you think you don’t need.

    If I were you, I would contact GoDaddy and explain that you’re assuming your theme and plugins have so many crop sizes registered that it’s killing the media upload process with however they’ve setup things on the server. Go from there, and see if there’s anything they can do to allocate more server resources to the process. They may have access to server error logging that you don’t. It could be a simple matter of increasing allocated memory, who knows.

    Anyway, I would do this because what you’re experiencing is not normal. There has to be something they can change on the server to allow things to work.

    #25683
    Mark Wiard
    Participant

    Filtering the crop sizes worked, and seems like the perfect solution.

    Thank you,
    mark

    For reference, this is what I started with. Now I can remove a few lines for the image sizes that the site actually uses.

    /* START turn off Jumpstart image crop sizes */
    function my_image_sizes( $sizes ) {
         
        unset($sizes['tb_x_large']);
        unset($sizes['tb_large']);
        unset($sizes['tb_medium']);
        unset($sizes['tb_thumb']);
        unset($sizes['tb_grid']);
        unset($sizes['tb_square_x_large']);
        unset($sizes['tb_square_large']);
        unset($sizes['tb_square_medium']);
        unset($sizes['slider-x-large']);
        unset($sizes['slider-large']);
        unset($sizes['slider-medium']);
        unset($sizes['slider-staged']);
    											 
        return $sizes;
     
    }
    add_filter( 'themeblvd_image_sizes', 'my_image_sizes' );
    /* END turn off Jumpstart image crop sizes */
    #25684
    Jason Bobich
    Keymaster

    Interestingly enough, WordPress 4.5 comes out tomorrow and one of the things they’re promoting in the developer notes is improvements on the process of generating and compressing all the image crop sizes. Out of curiosity you might try again after updating to WP 4.5.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.