This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

How to hide php notices

  • Creator
    Topic
  • #25220
    jakelivingston
    Participant

    I’m getting this message in my widget areas when I display mini post lists.

    Notice: Undefined index: square_ in C:\Inetpub\vhosts\kcsjcatholic.org\httpdocs\wp-content\themes\alyeska\framework\includes\parts.php on line 593

    How can i fix and/or hide these notices from website visitors?

    http://s12.postimg.org/tv3kwbrd9/screenshot.png

Viewing 8 replies - 1 through 8 (of 8 total)
  • Author
    Replies
  • #25221
    Jason Bobich
    Keymaster

    Hi,

    This would suggest that you don’t have a thumbnail size saved properly to the widget. Try going to Appearance > Widgets, and in the widget options, make sure a thumbnail size is selected and then save the widget settings. See if that does the trick for you.

    Also, obviously make sure that you have the latest version of the theme and the widget pack plugin installed.

    #25224
    jakelivingston
    Participant

    I’m actually trying to hide thumbnails on this widget rather than display them. Thumbnails are set to ‘hide’.

    #25225
    jakelivingston
    Participant

    I switched the setting from “hide” to “smallest” and the notice went away. It’s a short term solution because I don’t want to display thumbnails but at least it doesn’t look like a mistake right now.

    #25228
    Jason Bobich
    Keymaster

    Hm, are you up-to-date with everything? What version of the theme do you have?

    #25230
    jakelivingston
    Participant

    Theme Blvd Widget Pack
    Deactivate | Edit
    This plugin adds a pack of widgets that work with the Theme Blvd framework.

    Version 1.0.5 | By Theme Blvd | View details

    AlyeskaVersion: 3.1.6

    #25231
    Jason Bobich
    Keymaster

    I’m not sure updating will directly fix your issue. However there is a significant bug in your version theme with WordPress 4.2+ and applying styling from the theme options panel. And so it would probably be best to update anyway.

    http://themeblvd.com/changelog/?theme=alyeska

    And if that doesn’t solve your issue with the mini post list widget, you can provide me a live link to your site and I can write a CSS snippet for you to just hide the thumbnails.

    #25244
    jakelivingston
    Participant

    I followed the instructions on how to update my theme. I set it to auto-update but I also manually uploaded the latest version via a zip folder and it still shows me on v 3.1.6.

    #25250
    Jason Bobich
    Keymaster

    Then something you’re doing isn’t correct, and you should check what you’re doing with these files on your server through FTP, or however you’re managing them. Make sure the directory that you have activated on your WordPress Themes page matches the directory on your server holding all of the current files for that version.

    Maybe you’re not uploading and replacing files properly. Or, maybe you’ve uploaded the new files in a separate directory at /wp-content/themes/ that is not the name of the directory you currently have activated. There’s just no way for me to know from where I am; these are just wild guesses.

Viewing 8 replies - 1 through 8 (of 8 total)

The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.