This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Flexslider image maps, shortcodes

  • Creator
    Topic
  • #8640
    propagandalabs
    Participant

    Already searched the cybertubes, but I bet you know more: Flexslider > custom slide is completely ignoring the tag and yes it has a unique ID etc…I don’t love image maps but they are occasionally necessary and it’s such a basic tag there”s really no reason to block it. Another fail: I also tried a post content shortcode in the slide, but it doesn’t do shortcodes either. Ideas?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Author
    Replies
  • #8641
    propagandalabs
    Participant

    Btw tried iframe but flexslider ignores scrolling=”no” as well.

    #8650
    Jason Bobich
    Keymaster

    Currently the custom slides use the same sanitization as the text areas on your Theme Options page. Here’s how you can remove all sanitization for both from your Child theme’s functions.php:

    function my_sanitize_textarea( $input ){
    	// function required, but don't do any filtering...
    	return $input;
    }
    remove_filter( 'of_sanitize_textarea', 'of_sanitize_textarea' );
    add_filter( 'of_sanitize_textarea', 'my_sanitize_textarea' );
    #8664
    propagandalabs
    Participant

    Thank you!

    #10149
    propagandalabs
    Participant

    Jason,
    rel=”themeblvd_lightbox” doesn’t work on image maps. Is there more de-sanitzation code we need to add? In case you needed an example, the “watch video” link has the rel : http://s5556.p3.sites.pressdns.com/image-map-lightbox-test/

    #10162
    Jason Bobich
    Keymaster

    This is just HTML you’re putting in a post? The theme doesn’t do any sanitization here.

    But you’re referring to this I copied from your source, right?

    <area coords="42,133,409,237" shape="rect" href="http://www.youtube.com/watch?v=zeX-lyqIqeI" rel="themeblvd_lightbox" />

    I see this outputted on your page, but this isn’t how prettyPhoto is setup. You need to link from an anchor <a> tag. But you can see by viewing the source of your page that obviously this isn’t getting sanitized out.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The forum ‘Barely Corporate Responsive WordPress Theme’ is closed to new topics and replies.