This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Featured Images on single pages link to themselves

  • Creator
    Topic
  • #26273
    srumery
    Participant

    I’ve got a site where we need featured images assigned to pages so they can be used for the Post Grid builder element we have on the homepage. The post grid on the homepage works as expected. It pulls the featured images and links to the pages. That works great. The single page display shows the featured image at the top and links to itself.

    The “Featured Image Link” Page Option for this specific page is set to “Featured image is not a link”. It doesn’t seem to honor this setting.

    This site is also using the Featured Image Override Link plugin. Those settings in the Configuration tab in Theme Options are as follows:

    Link Override = Featured images link to their posts.
    Single Posts = No, do not apply the above override to single posts.

    This plugin might not even affect the pages since it is geared toward Single Posts.

    We have the Super User theme base.

    Also, this CSS is putting the top part of the featured image on top of the lower portion of the page title.

    article.page>.featured-item {
        margin: -30px -30px 30px -30px;
    }

    We can override that easily but I though you might want to know about that.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Author
    Replies
  • #26274
    Jason Bobich
    Keymaster

    The FILO plugin is a big time hack to put automated featured image links into this theme and many others with different framework versions. So if it doesn’t work in every situation I’m not really going to stress over that.

    The big question is though, if you disable FILO plugin, are any of these options in the theme not working properly as you’re describing?

    #26276
    srumery
    Participant

    If I turn off the FILO plugin, the featured image is properly displaying on the single page. It is no longer linking to itself.

    Is there a workaround for this? Maybe a filter we can tap into to get the Page Option for handling the featured image to be honored.

    #26277
    Jason Bobich
    Keymaster

    So on all these pages, they could be set in individually two ways:

    1. Set to not have a link from Edit Page and thus take on FILO plugin’s settings.

    2. Set manually from Edit Page to link to post/page and for single post to not inherit that link.

    Which way are you doing it? Have you tried both ways?

    #26278
    Jason Bobich
    Keymaster

    By the way, where are you finding this?

    article.page>.featured-item {
        margin: -30px -30px 30px -30px;
    }

    … I’ve searched the entire theme directory and can’t find it anywhere in any CSS file?

    #26279
    srumery
    Participant

    /wp-content/themes/jumpstart/assets/css/theme.min.css?ver=2.0.3

    #26280
    Jason Bobich
    Keymaster

    Aw, yeah, that’s old and no longer exists. You’re a bit behind on your version of the theme.

    http://themeblvd.com/changelog/?theme=jumpstart

    #26281
    Jason Bobich
    Keymaster

    Being up-to-date could actually help your issue, too, because you could set the featured images on the single pages to be full-width, which means it’s not possible for them to have a link.

    http://demoblvd.com/themes/jumpstart-2/demo-1/practical-examples/full-width-featured/

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.