This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Featured Images – going round in circles

  • Creator
    Topic
  • #904
    phil1066
    Member

    I’ve recently started using featured images, in order to show thumbnails in post grids etc.

    When using the link to enlarged lightbox version, there are two problems:

    1) image description or title does not show
    2) the user is presented with arrows and is allowed to browse to images not contained in the post, but ones that are in the same category (or indeed search string)

    Something else I’m trying to achieve is to have the thumbnails in post list/grid non-clickable (which can be set) but still retain the option to have an enlarged image show in lightbox on the single post version. I’ve tried all combinations I can think of using the WordPress and theme options. Even tried hiding the image and using the standard pop-up lightbox, but on featured post pages you get two images showing – the featured one and the inserted gallery one.

    Any ideas?

Viewing 6 replies - 1 through 6 (of 6 total)
  • Author
    Replies
  • #920
    Jason Bobich
    Keymaster

    Hello,

    I’m afraid I don’t have much in the way of good news for you.

    1) image description or title does not show
    2) the user is presented with arrows and is allowed to browse to images not contained in the post, but ones that are in the same category (or indeed search string)

    I apologize, but there is not feature of the theme to alter either of these things.

    Something else I’m trying to achieve is to have the thumbnails in post list/grid non-clickable (which can be set) but still retain the option to have an enlarged image show in lightbox on the single post version.

    You could possibly just hide the featured image on the single post page via the “Post Options”. Then just insert the image manually at the top of the post. Link it the lightbox and maybe give it the class “pretty” so it has a nice little frame around it.

    
       
    

    … but on featured post pages you get two images showing.

    And then because you see this happening, you’ll need to use excerpts where ever you’re displaying the posts.

    #935
    phil1066
    Member

    Thanks Jason for the suggestions – I’ve been using the ‘themeblvd_lightbox’ in the image options but not that not all of them are applying. Its seems a bit random – sometimes the code saves in the link rel box, other times it just doesnt stay there – bit random really.

    Have tried editing the code in the HTML view on the posts that dont work in order to match posts that do show the lightbox working, but then the lightbox image never loads – just getting the whirly wheel

    see http://motography.co/1951-austin-hot-rod/

    • This reply was modified 7 years, 9 months ago by phil1066. Reason: added detail
    #943
    Jason Bobich
    Keymaster

    I’ve been using the ‘themeblvd_lightbox’ in the image options but not that not all of them are applying.

    What does this mean, exactly? What do you mean “in the image options”? This is how you apply lightbox manually to an image: https://vimeo.com/32560047

    You place the rel="themeblvd_lightbox" attribute in the HTML where the anchor tag is.

    #944
    Jason Bobich
    Keymaster

    On that example you’re linking to the problem is because your HTML code is invalid. On your anchor tag, the image you’re linking to is just randomly in the anchor tag and it’s not within an href parameter.

    So you have this:

    But it should be this:

    Note: Ignore the rel="nofollow" — My website is automatically putting that in there when save the Reply.

    #945
    phil1066
    Member

    Thanks Jason 🙂 to achieve the lightbox pop-up I’ve been adding the “themeblvd_lightbox” code into the Advanced Link Settings box “Link Rel” as I noticed it showed up there – guess I was trying to avoid using the HTML editor for fear of not doing something correctly – which it turns out I have – given your comments above 🙂

    #948
    phil1066
    Member

    All sorted now – thanks again mate 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The forum ‘Alyeska Responsive WordPress Theme’ is closed to new topics and replies.