This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Excerpt, Read More, etc.

  • Creator
    Topic
  • #7453
    laurah
    Participant

    Jason,

    I love the Jump Start framework, thank you! I have a few things I’ve been trying to change, without success.

    1) Trying to remove the “read more” from home page where I’m using post list. I followed instructions posted here for the post grid, but that did not work, obviously.
    2) Would like to change the length of the excerpt on the post list on the home page.
    3) When I import the site content, the comments came in and show up, but where it state the number of comments, it says 0. ex: http://memoriesofhollywood.com/redesign/new-york-at-night/

    Thanks in advance for any help you can offer!
    Laura

Viewing 4 replies - 1 through 4 (of 4 total)
  • Author
    Replies
  • #7455
    Jason Bobich
    Keymaster

    Hello Laura,

    Glad to hear you’re liking the framework!

    1) The function that controls this is called themeblvd_blog_content_default found in /framework/frontend/functions/display.php and is hooked to “themeblvd_blog_content” (although I just noticed the comment in the framework’s source code above the function is incorrect and says it’s hooked to “themeblvd_content”).

    You’d either edit this function or remove the default and hook your own. (You’re essentially just removing the part about echoing the $button towards the bottom.)

    2) By default, WordPress will take the first 55 words of your post to use as the excerpt. Or, you can manually write out the excerpt for any post within the meta box titled “Excerpt” when editing the given post.

    Note: If you do not see the “Excerpt” meta box when editing a post, it means you have it hidden. Go to “Screen Options” at the top right corner of the screen and select to show it.

    Additionally, if you search over on wordpress.org, there are several cool, little plugins you can explore for messing with the excerpt.

    http://wordpress.org/extend/plugins/search.php?q=excerpt+length

    3) Honestly I don’t think I’ve ever heard of something like this in supporting any theme; that is very strange. The way the theme is displaying comments numbers is just the absolute basic in theming, really, and the standard default WordPress functions I know that I personally have been using forever. Something has to be up with your specific setup of your site in some way.

    Can you think of anything strange that might be on your end in this regard? Do you have any plugins installed that would effect comments in any way? Is the issue with comments or the imported data? Meaning if you were to create a new post manually and add a comment, does that work, or do you get the same result? These are questions that maybe could lead to an answer. If you figure it out please let me know, as I’m very curious to know what could cause such a thing.

    #7661
    laurah
    Participant

    Jason,

    Thank you for your reply and help on those matters. I ended up adding a function to change the excerpt length:

    function custom_excerpt_length( $length ) {
    	return 200;
    }
    add_filter( 'excerpt_length', 'custom_excerpt_length', 999 );

    I decided I like your Read More link and am keeping it as is.

    and on the third problem about comments counts showing… I deleted all the posts and reimported them and everything was fine. I remember there was a “slow down” on my internet connect due to a storm and the upload must have been interrupted!

    NOW, one more (hopefully that’s all) question: the home page continued pages links do not go to the next page. When you click on a page number or next page it stays right there on the home page. Other pages I set up continue to the next page without a problem and I’m using Post Grid for them.

    http://i36.tinypic.com/s5i640.png

    Thank you again!

    #7672
    Jason Bobich
    Keymaster

    NOW, one more (hopefully that’s all) question: the home page continued pages links do not go to the next page. When you click on a page number or next page it stays right there on the home page. Other pages I set up continue to the next page without a problem and I’m using Post Grid for them.

    This is because WordPress doesn’t like when you have a static frontpage with pagination. When using a custom layout for your homepage that includes any paginated element, here’s how you should set it up. —

    1. Go to Settings > Reading > Frontpage displays and select “your latest posts.”
    2. Go to Appearance > Theme Options > Content > Homepage and apply your custom layout.
    #8024
    laurah
    Participant

    Thank you for this Jason!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.