This is searchable archive of our old support forums, which operated from 2012 - 2016. To find out how to get support for your current theme, please visit our support page.

Error with child theme: The themes directory is either empty or doesn’t exist.

  • Creator
    Topic
  • #4106
    imagedept.
    Member

    Hello, I have been customizing the Swagger theme today and have received this error message “ERROR: The themes directory is either empty or doesn’t exist. Please check your installation.” I have the child theme installed. Do you have any suggestions as to how I may correct this?

    Thanks in advance.

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • #4110
    Jason Bobich
    Keymaster

    Hello,

    Either you don’t have the Swagger parent theme present or uploaded correctly to your /wp-content/themes/ directory, or you don’t have linked up right from your Child theme.

    First, obviously ensure you have the Swagger parent theme located in your themes directory along with your Child theme. Next, at the top of your child theme’s style.css, you need to make sure the “template” parameter matches the name of the directory that you have the Swagger theme’s files located in.

    If you upload the default swagger theme and swagger child theme through your WordPress admin panel the way they’ve been included in your download package from ThemeForest, you shouldn’t be getting any errors like this. The default Swagger theme comes in a folder called “swagger” and then you will see that the Child theme’s style.css has a matching template parameter that is also “swagger” to match the name of that folder.

    If you can’t figure out what you’ve done with the information, feel free to tell me a little more about what you’ve done in installing the theme, where you’re uploading things, what you’ve changed, etc.

    #4114
    imagedept.
    Member

    Thank you, somehow I must have altered the style.css file instead of the custom.css file through the Theme Editor. The style.css “template” parameter was not there. I added it and now the error message is gone and I can continue with my customizations. Sorry for the mistake on my part.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The forum ‘Swagger Responsive WordPress Theme’ is closed to new topics and replies.